generic: 6.1: backport support for Marvell 88E6361 switch
[openwrt/staging/jow.git] / include / prereq.mk
index 546f36b8e3e8a54628870bf2c90602580b9718c0..1039c5540c6a01a17d61851a7aa2f334d8eb1df4 100644 (file)
@@ -107,16 +107,9 @@ define SetupHostCommand
                        bin="$$$$$$$$(command -v "$$$$$$$${cmd%% *}")"; \
                        if [ -x "$$$$$$$$bin" ] && eval "$$$$$$$$cmd" >/dev/null 2>/dev/null; then \
                                case "$$$$$$$$(ls -dl -- $(STAGING_DIR_HOST)/bin/$(strip $(1)))" in \
-                                       *" -> $$$$$$$$bin"*) \
-                                               [ -x "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0 \
-                                               ;; \
-                                       "-"*) \
-                                               find "$(STAGING_DIR_HOST)/stamp" | grep $(strip $(1)) && \
-                                               [ -x "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0 \
-                                               ;; \
-                                       *" -> /"*) \
-                                               ;; \
-                                       *" -> "*) \
+                                       "-"* | \
+                                       *" -> $$$$$$$$bin"* | \
+                                       *" -> "[!/]*) \
                                                [ -x "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0 \
                                                ;; \
                                esac; \