ipq807x: mark MDT loader fix as backport
[openwrt/staging/jow.git] / include / prereq.mk
index 45c84e984c6f2942ac34b7b2a5153bcfcf8969ac..546f36b8e3e8a54628870bf2c90602580b9718c0 100644 (file)
@@ -110,9 +110,18 @@ define SetupHostCommand
                                        *" -> $$$$$$$$bin"*) \
                                                [ -x "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0 \
                                                ;; \
+                                       "-"*) \
+                                               find "$(STAGING_DIR_HOST)/stamp" | grep $(strip $(1)) && \
+                                               [ -x "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0 \
+                                               ;; \
+                                       *" -> /"*) \
+                                               ;; \
+                                       *" -> "*) \
+                                               [ -x "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0 \
+                                               ;; \
                                esac; \
                                ln -sf "$$$$$$$$bin" "$(STAGING_DIR_HOST)/bin/$(strip $(1))"; \
-                               exit 0; \
+                               exit 1; \
                        fi; \
                fi; \
        done; \