prereq-build: allow host command symlinks to update
[openwrt/staging/ldir.git] / include / prereq.mk
index c11178a884b4b450ee4fb585785a3ec1bb0cd998..89660d323d9b82858ffda8498255522ed84b7aaa 100644 (file)
@@ -30,6 +30,8 @@ define Require
                printf "Checking '$(1)'... "
                if $(NO_TRACE_MAKE) -f $(firstword $(MAKEFILE_LIST)) check-$(1) >/dev/null 2>/dev/null; then \
                        echo 'ok.'; \
+               elif $(NO_TRACE_MAKE) -f $(firstword $(MAKEFILE_LIST)) check-$(1) >/dev/null 2>/dev/null; then \
+                       echo 'updated.'; \
                else \
                        echo 'failed.'; \
                        echo "$(PKG_NAME): $(strip $(2))" >> $(TMP_DIR)/.prereq-error; \
@@ -49,7 +51,7 @@ endef
 
 define RequireCommand
   define Require/$(1)
-    command -pv $(1)
+    command -v $(1)
   endef
 
   $$(eval $$(call Require,$(1),$(2)))
@@ -63,6 +65,18 @@ define RequireHeader
   $$(eval $$(call Require,$(1),$(2)))
 endef
 
+# 1: header to test
+# 2: failure message
+# 3: optional compile time test
+# 4: optional link library test (example -lncurses)
+define RequireCHeader
+  define Require/$(1)
+    echo 'int main(int argc, char **argv) { $(3); return 0; }' | gcc -include $(1) -x c -o $(TMP_DIR)/a.out - $(4)
+  endef
+
+  $$(eval $$(call Require,$(1),$(2)))
+endef
+
 define CleanupPython2
   define Require/python2-cleanup
        if [ -f "$(STAGING_DIR_HOST)/bin/python" ] && \
@@ -95,7 +109,7 @@ endef
 # 3+: candidates
 define SetupHostCommand
   define Require/$(1)
-       [ -f "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0; \
+       mkdir -p "$(STAGING_DIR_HOST)/bin"; \
        for cmd in $(call QuoteHostCommand,$(3)) $(call QuoteHostCommand,$(4)) \
                   $(call QuoteHostCommand,$(5)) $(call QuoteHostCommand,$(6)) \
                   $(call QuoteHostCommand,$(7)) $(call QuoteHostCommand,$(8)) \
@@ -103,11 +117,15 @@ define SetupHostCommand
                   $(call QuoteHostCommand,$(11)) $(call QuoteHostCommand,$(12)); do \
                if [ -n "$$$$$$$$cmd" ]; then \
                        bin="$$$$$$$$(PATH="$(subst $(space),:,$(filter-out $(STAGING_DIR_HOST)/%,$(subst :,$(space),$(PATH))))" \
-                               command -pv "$$$$$$$${cmd%% *}")"; \
+                               command -v "$$$$$$$${cmd%% *}")"; \
                        if [ -x "$$$$$$$$bin" ] && eval "$$$$$$$$cmd" >/dev/null 2>/dev/null; then \
-                               mkdir -p "$(STAGING_DIR_HOST)/bin"; \
+                               case "$$$$$$$$(ls -dl -- $(STAGING_DIR_HOST)/bin/$(strip $(1)))" in \
+                                       *" -> $$$$$$$$bin"*) \
+                                               [ -x "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0 \
+                                               ;; \
+                               esac; \
                                ln -sf "$$$$$$$$bin" "$(STAGING_DIR_HOST)/bin/$(strip $(1))"; \
-                               exit 0; \
+                               exit 1; \
                        fi; \
                fi; \
        done; \