Make the libtool fix more dynamic
[openwrt/staging/yousong.git] / include / subdir.mk
index 4348c7b93d8b4f85734036d058b0c01c1988e2b3..217d6bc3768c2a2755e4dd56b8cf4e33f79e4915 100644 (file)
@@ -23,7 +23,7 @@ define subdir
   $(foreach bd,$($(1)/builddirs),
     $(call warn,$(1),d,BD $(1)/$(bd))
     $(foreach target,$(SUBTARGETS),
-      $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd)))
+      $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $(if $(QUILT),,$($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd))))
                +$$(MAKE) -j1 -C $(1)/$(bd) $(target)
         $$(if $(call debug,$(1)/$(bd),v),,.SILENT: $(1)/$(bd)/$(target))
 
@@ -36,8 +36,8 @@ endef
 
 # Parameters: <subdir> <name> <target>
 define stampfile
-  $(1)/stamp-$(3):=$(STAGING_DIR)/stampfiles/.$(2)_$(3)
-  $(if __rdep_$(1),,
+  $(1)/stamp-$(3):=$(STAGING_DIR)/stamp/.$(2)_$(3)
+  $(if $(__rdep_$(1)),,
     $(call rdep,$(1),$$($(1)/stamp-$(3)),)
     __rdep_$(1):=1
   )