build: show make output in scripts/config when V=s
[openwrt/staging/dedeckeh.git] / include / toplevel.mk
index def80503dd911d209d55bfa7a79fc3dd83f79d1c..ad8e5b8f20428e7b81054e367dbc782258f0d43a 100644 (file)
@@ -102,9 +102,10 @@ prepare-tmpinfo: FORCE
 ifneq ($(DISTRO_PKG_CONFIG),)
 scripts/config/%onf: export PATH:=$(dir $(DISTRO_PKG_CONFIG)):$(PATH)
 endif
-scripts/config/%onf: CFLAGS+= -O2 $(if $(WARN_RECURSIVE_DEP),-DWARN_RECURSIVE_DEP)
+scripts/config/%onf: CFLAGS+= -O2
 scripts/config/%onf:
-       @$(_SINGLE)$(SUBMAKE) -s -C scripts/config $(notdir $@) CC="$(HOSTCC_WRAPPER)"
+       @$(_SINGLE)$(SUBMAKE) $(if $(findstring s,$(OPENWRT_VERBOSE)),,-s) \
+               -C scripts/config $(notdir $@) CC="$(HOSTCC_WRAPPER)"
 
 $(eval $(call rdep,scripts/config,scripts/config/mconf))