ubus: update to the latest version, fixes a segfault on message retry
[openwrt/svn-archive/archive.git] / include / toplevel.mk
index 2e13f623dcab8ae5a38e13148ce1481080a4c1d9..bbeb7ebcefbf8e50178c2110b376b0300dd9ada9 100644 (file)
@@ -161,11 +161,13 @@ download: .config FORCE
        @+$(SUBMAKE) target/download
 
 clean dirclean: .config
-       @+$(SUBMAKE) -r $@ 
+       @+$(SUBMAKE) -r $@
 
 prereq:: prepare-tmpinfo .config
        @+$(NO_TRACE_MAKE) -r -s $@
 
+WARN_PARALLEL_ERROR = $(if $(BUILD_LOG),,$(and $(filter -j,$(MAKEFLAGS)),$(findstring s,$(OPENWRT_VERBOSE))))
+
 ifeq ($(SDK),1)
 
 %::
@@ -184,10 +186,27 @@ else
                        printf "$(_R)WARNING: your configuration is out of sync. Please run make menuconfig, oldconfig or defconfig!$(_N)\n" >&2; \
                fi \
        )
-       @+$(ULIMIT_FIX) $(SUBMAKE) -r $@
+       @+$(ULIMIT_FIX) $(SUBMAKE) -r $@ $(if $(WARN_PARALLEL_ERROR), || { \
+               printf "$(_R)Build failed - please re-run with -j1 to see the real error message$(_N)\n" >&2; \
+               false; \
+       } )
 
 endif
 
+# update all feeds, re-create index files, install symlinks
+package/symlinks:
+       ./scripts/feeds update -a
+       ./scripts/feeds install -a
+
+# re-create index files, install symlinks
+package/symlinks-install:
+       ./scripts/feeds update -i
+       ./scripts/feeds install -a
+
+# remove all symlinks, don't touch ./feeds
+package/symlinks-clean:
+       ./scripts/feeds uninstall -a
+
 help:
        cat README