nls.mk: remove libiconv-stub
[openwrt/staging/stintel.git] / include / u-boot.mk
index 0c2865332631f03f7c7920701ce4e073af1e3c89..8945e8e2b8f5682e46bac6d574c3beb761768def 100644 (file)
@@ -3,7 +3,8 @@ PKG_NAME ?= u-boot
 ifndef PKG_SOURCE_PROTO
 PKG_SOURCE = $(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL = \
-       http://sources.lede-project.org \
+       https://mirror.cyberbits.eu/u-boot \
+       https://ftp.denx.de/pub/u-boot \
        ftp://ftp.denx.de/pub/u-boot
 endif
 
@@ -40,6 +41,17 @@ endef
 
 TARGET_DEP = TARGET_$(BUILD_TARGET)$(if $(BUILD_SUBTARGET),_$(BUILD_SUBTARGET))
 
+UBOOT_MAKE_FLAGS = \
+       HOSTCC="$(HOSTCC)" \
+       HOSTCFLAGS="$(HOST_CFLAGS) $(HOST_CPPFLAGS) -std=gnu11" \
+       HOSTLDFLAGS="$(HOST_LDFLAGS)" \
+       LOCALVERSION="-OpenWrt-$(REVISION)" \
+       STAGING_PREFIX="$(STAGING_DIR_HOST)" \
+       PKG_CONFIG_PATH="$(STAGING_DIR_HOST)/lib/pkgconfig" \
+       PKG_CONFIG_LIBDIR="$(STAGING_DIR_HOST)/lib/pkgconfig" \
+       PKG_CONFIG_EXTRAARGS="--static" \
+       $(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='')
+
 define Build/U-Boot/Target
   $(eval $(call U-Boot/Init,$(1)))
   $(eval $(call U-Boot/Default,$(1)))