[package] fix libnids compilation failure (#6947)
[openwrt/svn-archive/archive.git] / ipv6 / ipv6calc / Makefile
index 18aa47d330d85cca7dd028d7773395cd1ecb2a39..b817abf54b380c6b2a8ad1e7bb7c8101b33e5e28 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -8,11 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ipv6calc
-PKG_VERSION:=0.71.0
+PKG_VERSION:=0.73.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.bieringer.de/pub/linux/IPv6/ipv6calc/
-PKG_MD5SUM:=
+PKG_MD5SUM:=24141d637207532ea9a9881f968d086f
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -24,10 +25,12 @@ define Package/ipv6calc
 endef
 
 define Package/ipv6calc/description
-  ipv6calc is a small utility written in programming languate C to manipulate (not only) IPv6 addresses.
-  Intentions were convering a given IPv6 address into compressed format, convering a given IPv6 address
-  into the same format like shown in /proc/net/if_inet6 and (because it was not difficulty) migrating the
-  Perl program ip6_int into. Now only one utiltity is needed to do a lot.
+  ipv6calc is a small utility written in programming languate C to manipulate
+  (not only) IPv6 addresses. Intentions were convering a given IPv6 address
+  into compressed format, convering a given IPv6 address into the same format
+  like shown in /proc/net/if_inet6 and (because it was not difficulty)
+  migrating the Perl program ip6_int into. Now only one utiltity is needed to
+  do a lot.
 endef
 
 CONFIGURE_ARGS += \
@@ -38,14 +41,13 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                COPTS="$(TARGET_CFLAGS) -I$(PKG_BUILD_DIR)" \
-               root="$(PKG_INSTALL_DIR)" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
-
 define Package/ipv6calc/install
-       $(INSTALL_DIR) $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ipv6* $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ipv6* $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,ipv6calc))