[packages] hiawatha: update to 7.0
[openwrt/svn-archive/archive.git] / ipv6 / tspc / Makefile
index 4853e31d2fd8b4c5bfa193cd7ae7a9ccbe69e1cb..6e76748e731fa4f245d3cf19c45ade18187a5cc3 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,7 +14,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=http://ftp.fr.debian.org/debian/pool/main/t/tspc/
 PKG_MD5SUM:=65183cae002feaacd8bc92d6a5404cc2
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)2
 
@@ -25,21 +23,26 @@ define Package/tspc
   SECTION:=ipv6
   CATEGORY:=IPv6
   TITLE:=Client for Hexago's (Freenet6's) IPv6 service
-  DESCRIPTION:=\
-       Client to configure an IPv6 tunnel to \\\
-       Hexago's (Freenet6's) migration broker.
   URL:=http://www.hexago.com
 endef
 
+define Package/tspc/description
+       Client to configure an IPv6 tunnel to 
+       Hexago's (Freenet6's) migration broker.
+endef
+
 MAKE_FLAGS += \
        CFLAGS="$(TARGET_CFLAGS) -I$(PKG_BUILD_DIR)/include -I$(PKG_BUILD_DIR)/platform/linux" \
-       target=linux
+       target=linux \
+       all
 
 define Package/tspc/install
        $(INSTALL_DIR) $(1)/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/tspc $(1)/bin/
        $(INSTALL_DIR) $(1)/etc/tsp
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/bin/tspc.conf.sample $(1)/etc/tsp/tspc.conf
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/bin/tspc.conf.sample $(1)/etc/tsp/tspc.conf
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/template/linux.sh $(1)/etc/tsp/setup.sh
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/template/checktunnel.sh $(1)/etc/tsp/
 endef
 
 $(eval $(call BuildPackage,tspc))