[packages] Use include_mk
[openwrt/svn-archive/archive.git] / lang / cython / Makefile
index bccaec14aecf882493096166d4a68a2305d3dd9c..0e02fdf2e5d469c783d3c8b1e88f6743ca1aa7b8 100644 (file)
@@ -1,22 +1,25 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 13829 2009-01-03 00:28:00Z mirko $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cython
 PKG_VERSION:=0.10.3
 PKG_RELEASE:=1
+
 PKG_SOURCE:=Cython-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.cython.org/
 PKG_BUILD_DIR:=$(BUILD_DIR)/Cython-$(PKG_VERSION)
+PKG_MD5SUM:=684103ed37472d9beef3a38e0d5c431d
+
+PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
--include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+$(call include_mk, python-package.mk)
 
 define Package/cython
   SUBMENU:=Python
@@ -24,7 +27,7 @@ define Package/cython
   CATEGORY:=Languages
   TITLE:=cython
   URL:=http://www.cython.org
-  DEPENDS:=python-core @BROKEN
+  DEPENDS:=+python-mini
 endef
 
 define Package/cython/description
@@ -32,7 +35,8 @@ define Package/cython/description
 endef
 
 define Build/Compile
-       $(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
+       # <--no-cython-compile> required, otherwise setup.py calls the target-gcc to create so-files which obviously can't be used by <python> on the host system.
+       $(call Build/Compile/PyMod,,install --no-cython-compile --prefix="$(PKG_INSTALL_DIR)/usr")
 endef
 
 define Build/InstallDev