[packages] procps: update to v3.2.8
[openwrt/svn-archive/archive.git] / lang / egenix-mx / Makefile
index 3f894eef48b32b41113f61a1e432280374c25e3b..559c6e90777a2a2ea411a575a1bc3e143108639f 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -13,7 +12,7 @@ PKG_VERSION:=2.0.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-base-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.egenix.com/files/python/
+PKG_SOURCE_URL:=http://downloads.egenix.com/python/
 PKG_MD5SUM:=66841151728a06f92d0b8dd2ed317a29
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-base-$(PKG_VERSION)
@@ -21,14 +20,12 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/python-egenix-mx
+  SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
-  DEPENDS:=python-core
+  DEPENDS:=+python-mini
   TITLE:=Egenix mxBase
   URL:=http://www.egenix.com/products/python/mxBase/
 endef
@@ -39,6 +36,7 @@ define Package/python-egenix-mx/description
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                build --build-lib="foo", \
                BASECFLAGS="$(TARGET_CFLAGS)" \
@@ -82,10 +80,6 @@ define Build/InstallDev
                $(1)$(PYTHON_PKG_DIR)/mx/Tools/mxTools/
 endef
 
-define Build/UninstallDev
-       rm -rf $(STAGING_DIR)$(PYTHON_PKG_DIR)/mx
-endef
-
 define PyPackage/python-egenix-mx/install
        $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
        $(CP) $(PKG_BUILD_DIR)/foo/mx $(1)$(PYTHON_PKG_DIR)/