lang/perl: Upgraded to Perl 5.24.1
[feed/packages.git] / lang / perl / perlmod.mk
index 173e890a8bbe8927696178852f9238e6c3c8c268..f65c8427d340428ea85de84617ff94bf0ea70958 100644 (file)
@@ -1,7 +1,7 @@
 # This makefile simplifies perl module builds.
 #
 
-PERL_VERSION:=5.22
+PERL_VERSION:=5.24
 
 # Build environment
 HOST_PERL_PREFIX:=$(STAGING_DIR_HOSTPKG)/usr
@@ -129,9 +129,7 @@ define perlmod/Install/NoStrip
 endef
 
 
-define perlmod/Install
-       $(call perlmod/Install/NoStrip,$(1),$(2),$(3))
-
+define perlmod/_DoStrip
        @echo "---> Stripping modules in: $(strip $(1))$(PERL_SITELIB)"
        find $(strip $(1))$(PERL_SITELIB) -name \*.pm -or -name \*.pl | \
        xargs -r sed -i \
@@ -141,6 +139,12 @@ define perlmod/Install
                -e '/^#[^!"'"'"']/d'
 endef
 
+define perlmod/Install
+       $(call perlmod/Install/NoStrip,$(1),$(2),$(3))
+
+       $(if $(CONFIG_PERL_NOCOMMENT),$(if $(PKG_LEAVE_COMMENTS),,$(call perlmod/_DoStrip,$(1),$(2),$(3))))
+endef
+
 # You probably don't want to use this directly. Look at perlmod/InstallTests
 define perlmod/_InstallTests
        $(INSTALL_DIR) $(strip $(1))