Add php5-exif module (#4188), bump release number
[openwrt/svn-archive/archive.git] / lang / php5 / Makefile
index 2690854be39545d3a0a054b152661a78faf35509..9c823263abe5cb954d03fa4803529c116039585c 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006,2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,67 +9,70 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
-PKG_VERSION:=5.1.6
-PKG_RELEASE:=1
+PKG_VERSION:=5.2.6
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://fr.php.net/distributions/
-PKG_MD5SUM:=08e423aa314369d4392a36b3f7246afc
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=http://www.php.net/distributions/
+PKG_MD5SUM:=7380ffecebd95c6edb317ef861229ebd
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/php5/Default
+  SUBMENU:=PHP
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=PHP5 Hypertext preprocessor
-  DESCRIPTION:=\
-       PHP is a widely-used general-purpose scripting language that is especially \\\
-       suited for Web development and can be embedded into HTML.
   URL:=http://www.php.net/
 endef
 
+define Package/php5/Default/description
+ PHP is a widely-used general-purpose scripting language that is especially 
+ suited for Web development and can be embedded into HTML.
+endef
+
 define Package/php5
   $(call Package/php5/Default)
   DEPENDS:=+libopenssl +zlib
-  DESCRIPTION+=\\\
-       \\\
-       This package contains only the PHP config file. You must actually choose your \\\
-       PHP flavour (cli, cgi or fastcgi).
-  MENU:=1
 endef
 
-define Package/php5/conffiles
-/etc/php.ini
+define Package/php5/description
+$(call Package/php5/Default/description)
+ This package contains only the PHP config file. You must actually choose 
+ your PHP flavour (cli, cgi or fastcgi).
 endef
 
 define Package/php5-cli
   $(call Package/php5/Default)
   DEPENDS:=php5
   TITLE+= (CLI)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the CLI version of the PHP5 interpreter.
+endef
+
+define Package/php5-cli/description
+$(call Package/php5/Default/description)
+ This package contains the CLI version of the PHP5 interpreter.
 endef
 
 define Package/php5-cgi
   $(call Package/php5/Default)
   DEPENDS:=php5
   TITLE+= (CGI)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the CGI version of the PHP5 interpreter.
+endef
+
+define Package/php5-cgi/description
+$(call Package/php5/Default/description)
+ This package contains the CGI version of the PHP5 interpreter.
 endef
 
 define Package/php5-fastcgi
   $(call Package/php5/Default)
   DEPENDS:=php5
   TITLE+= (FastCGI)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the FastCGI version of the PHP5 interpreter.
+endef
+
+define Package/php5-fastcgi/description
+$(call Package/php5/Default/description)
+ This package contains the FastCGI version of the PHP5 interpreter.
 endef
 
 define Package/php5-mod-curl
@@ -98,7 +101,7 @@ endef
 
 define Package/php5-mod-ldap
   $(call Package/php5/Default)
-  DEPENDS:=php5 +libopenldap
+  DEPENDS:=php5 +libopenldap +libsasl2
   TITLE:=LDAP module
 endef
 
@@ -144,6 +147,18 @@ define Package/php5-mod-sqlite
   TITLE:=SQLite module
 endef
 
+define Package/php5-mod-pdo
+  $(call Package/php5/Default)
+  DEPENDS:=php5
+  TITLE:=PHP Data Objects module
+endef
+
+define Package/php5-mod-pdo-sqlite
+  $(call Package/php5/Default)
+  DEPENDS:=php5-mod-pdo +libsqlite3
+  TITLE:=PHP Data Objects module - SQLite support
+endef
+
 define Package/php5-mod-xml
   $(call Package/php5/Default)
   DEPENDS:=php5 +libexpat
@@ -156,6 +171,12 @@ define Package/php5-mod-apc
   TITLE:=APC Extension
 endef
 
+define Package/php5-mod-exif
+  $(call Package/php5/Default)
+  DEPENDS:=php5
+  TITLE:=EXIF Extension
+endef
+
 PKG_CONFIGURE_LIBS:= -lcrypto -lssl
 PKG_CONFIGURE_OPTS:= \
        --enable-shared \
@@ -192,6 +213,7 @@ PKG_CONFIGURE_OPTS:= \
        --disable-tokenizer \
        --with-zlib="$(STAGING_DIR)/usr" \
          --with-zlib-dir="$(STAGING_DIR)/usr" \
+       --disable-filter
 
 ifneq ($(SDK),)
   PKG_BUILD_DEPENDS:=libopenssl zlib libcurl libgd libgmp libopenldap libmysqlclient libpq libsqlite2 libexpat
@@ -222,7 +244,7 @@ ifneq ($(CONFIG_PACKAGE_php5-mod-gd),)
        --with-png-dir="$(STAGING_DIR)/usr" \
        --without-xpm-dir \
        --without-ttf \
-       --without-t1lib \
+       --without-t1lib \
        --enable-gd-native-ttf \
        --disable-gd-jis-conv
 else
@@ -259,6 +281,14 @@ ifneq ($(CONFIG_PACKAGE_php5-mod-sqlite),)
 else
   PKG_CONFIGURE_OPTS+= --without-sqlite
 endif
+ifneq ($(CONFIG_PACKAGE_php5-mod-pdo),)
+  PKG_CONFIGURE_OPTS+= --enable-pdo=shared
+  ifneq ($(CONFIG_PACKAGE_php5-mod-pdo-sqlite),)
+    PKG_CONFIGURE_OPTS+= --with-pdo-sqlite=shared,"$(STAGING_DIR)/usr"
+  endif
+else
+  PKG_CONFIGURE_OPTS+= --disable-pdo
+endif
 ifneq ($(CONFIG_PACKAGE_php5-mod-xml),)
   PKG_CONFIGURE_OPTS+= --enable-xml=shared,"$(STAGING_DIR)/usr" \
        --with-libexpat-dir="$(STAGING_DIR)/usr"
@@ -266,11 +296,16 @@ else
   PKG_CONFIGURE_OPTS+= --disable-xml
 endif
 ifneq ($(CONFIG_PACKAGE_php5-mod-apc),)
-  PKG_CONFIGURE_OPTS+= --enable-apc --disable-apc-mmap
+  PKG_CONFIGURE_OPTS+= --enable-apc --disable-apc-mmap --disable-apc-pthreadmutex
   PKG_CONFIGURE_LIBS+= -lrt
 else
   PKG_CONFIGURE_OPTS+= --disable-apc
 endif
+ifneq ($(CONFIG_PACKAGE_php5-mod-exif),)
+  PKG_CONFIGURE_OPTS+= --enable-exif
+else
+  PKG_CONFIGURE_OPTS+= --disable-exif
+endif
 
 define Build/Configure
 endef
@@ -309,7 +344,7 @@ ifneq ($(CONFIG_PACKAGE_php5-cgi),)
                php_cv_cc_rpath="no" \
        )
        $(MAKE) -C $(PKG_BUILD_DIR)
-       mv $(PKG_BUILD_DIR)/sapi/cgi/php $(PKG_BUILD_DIR)/php-cgi
+       mv $(PKG_BUILD_DIR)/sapi/cgi/php-cgi $(PKG_BUILD_DIR)/php-cgi
   endef
 endif
 
@@ -330,7 +365,7 @@ ifneq ($(CONFIG_PACKAGE_php5-fastcgi),)
                php_cv_cc_rpath="no" \
        )
        $(MAKE) -C $(PKG_BUILD_DIR)
-       mv $(PKG_BUILD_DIR)/sapi/cgi/php $(PKG_BUILD_DIR)/php-fastcgi
+       mv $(PKG_BUILD_DIR)/sapi/cgi/php-cgi $(PKG_BUILD_DIR)/php-fcgi
   endef
 endif
 
@@ -340,6 +375,10 @@ define Build/Compile
        $(call Build/Compile/php5-fastcgi)
 endef
 
+define Package/php5/conffiles
+/etc/php.ini
+endef
+
 define Package/php5/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/php.ini $(1)/etc/
@@ -347,17 +386,17 @@ endef
 
 define Package/php5-cli/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/php-cli $(1)/usr/bin/php
+       $(CP) $(PKG_BUILD_DIR)/php-cli $(1)/usr/bin/php-cli
 endef
 
 define Package/php5-cgi/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/php-cgi $(1)/usr/bin/php
+       $(CP) $(PKG_BUILD_DIR)/php-cgi $(1)/usr/bin/php-cgi
 endef
 
 define Package/php5-fastcgi/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/php-fastcgi $(1)/usr/sbin/php
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_BUILD_DIR)/php-fcgi $(1)/usr/bin/php-fcgi
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/php.init $(1)/etc/init.d/php
 endef
@@ -389,5 +428,8 @@ $(eval $(call BuildPlugin,php5-mod-pgsql,pgsql))
 $(eval $(call BuildPlugin,php5-mod-session,session))
 $(eval $(call BuildPlugin,php5-mod-sockets,sockets))
 $(eval $(call BuildPlugin,php5-mod-sqlite,sqlite))
+$(eval $(call BuildPlugin,php5-mod-pdo,pdo))
+$(eval $(call BuildPlugin,php5-mod-pdo-sqlite,pdo_sqlite))
 $(eval $(call BuildPlugin,php5-mod-xml,xml))
 $(eval $(call BuildPlugin,php5-mod-apc))
+$(eval $(call BuildPlugin,php5-mod-exif))