[packages] sqlite3: bump to v3.6.13 (#5029)
[openwrt/svn-archive/archive.git] / lang / php5 / Makefile
index 929099f49ba48c1422d4e03a93d8b0c8066c30a0..f9963600162413ff3c08e82e8b7fb0d3a3cfa0bc 100644 (file)
@@ -1,75 +1,77 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006,2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
-PKG_VERSION:=5.0.5
-PKG_RELEASE:=1
+PKG_VERSION:=5.2.6
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://fr.php.net/distributions/
-PKG_MD5SUM:=b5d4ca75bbb11ee5b830fa67213d9f7f
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=http://www.php.net/distributions/
+PKG_MD5SUM:=7380ffecebd95c6edb317ef861229ebd
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/php5/Default
+  SUBMENU:=PHP
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=PHP5 Hypertext preprocessor
-  DESCRIPTION:=\
-       PHP is a widely-used general-purpose scripting language that is especially \\\
-       suited for Web development and can be embedded into HTML.
   URL:=http://www.php.net/
 endef
 
+define Package/php5/Default/description
+ PHP is a widely-used general-purpose scripting language that is especially 
+ suited for Web development and can be embedded into HTML.
+endef
+
 define Package/php5
   $(call Package/php5/Default)
   DEPENDS:=+libopenssl +zlib
-  DESCRIPTION+=\\\
-       \\\
-       This package contains only the PHP config file. You must actually choose your \\\
-       PHP flavour (cli, cgi or fastcgi).
-  MENU:=1
 endef
 
-define Package/php5/conffiles
-/etc/php.ini
+define Package/php5/description
+$(call Package/php5/Default/description)
+ This package contains only the PHP config file. You must actually choose 
+ your PHP flavour (cli, cgi or fastcgi).
 endef
 
 define Package/php5-cli
   $(call Package/php5/Default)
   DEPENDS:=php5
   TITLE+= (CLI)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the CLI version of the PHP5 interpreter.
+endef
+
+define Package/php5-cli/description
+$(call Package/php5/Default/description)
+ This package contains the CLI version of the PHP5 interpreter.
 endef
 
 define Package/php5-cgi
   $(call Package/php5/Default)
   DEPENDS:=php5
   TITLE+= (CGI)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the CGI version of the PHP5 interpreter.
+endef
+
+define Package/php5-cgi/description
+$(call Package/php5/Default/description)
+ This package contains the CGI version of the PHP5 interpreter.
 endef
 
 define Package/php5-fastcgi
   $(call Package/php5/Default)
   DEPENDS:=php5
   TITLE+= (FastCGI)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the FastCGI version of the PHP5 interpreter.
+endef
+
+define Package/php5-fastcgi/description
+$(call Package/php5/Default/description)
+ This package contains the FastCGI version of the PHP5 interpreter.
 endef
 
 define Package/php5-mod-curl
@@ -98,7 +100,7 @@ endef
 
 define Package/php5-mod-ldap
   $(call Package/php5/Default)
-  DEPENDS:=php5 +libopenldap
+  DEPENDS:=php5 +libopenldap +libsasl2
   TITLE:=LDAP module
 endef
 
@@ -144,12 +146,36 @@ define Package/php5-mod-sqlite
   TITLE:=SQLite module
 endef
 
+define Package/php5-mod-pdo
+  $(call Package/php5/Default)
+  DEPENDS:=php5
+  TITLE:=PHP Data Objects module
+endef
+
+define Package/php5-mod-pdo-sqlite
+  $(call Package/php5/Default)
+  DEPENDS:=php5-mod-pdo +libsqlite3
+  TITLE:=PHP Data Objects module - SQLite support
+endef
+
 define Package/php5-mod-xml
   $(call Package/php5/Default)
   DEPENDS:=php5 +libexpat
   TITLE:=XML module
 endef
 
+define Package/php5-mod-apc
+  $(call Package/php5/Default)
+  DEPENDS:=php5
+  TITLE:=APC Extension
+endef
+
+define Package/php5-mod-exif
+  $(call Package/php5/Default)
+  DEPENDS:=php5
+  TITLE:=EXIF Extension
+endef
+
 PKG_CONFIGURE_LIBS:= -lcrypto -lssl
 PKG_CONFIGURE_OPTS:= \
        --enable-shared \
@@ -172,6 +198,8 @@ PKG_CONFIGURE_OPTS:= \
        --without-iconv \
        --disable-libxml \
          --without-libxml-dir \
+       --disable-xmlreader \
+       --disable-xmlwriter \
        --disable-mbstring \
        --disable-mbregex \
        --with-openssl=shared,"$(STAGING_DIR)/usr" \
@@ -184,6 +212,7 @@ PKG_CONFIGURE_OPTS:= \
        --disable-tokenizer \
        --with-zlib="$(STAGING_DIR)/usr" \
          --with-zlib-dir="$(STAGING_DIR)/usr" \
+       --disable-filter
 
 ifneq ($(SDK),)
   PKG_BUILD_DEPENDS:=libopenssl zlib libcurl libgd libgmp libopenldap libmysqlclient libpq libsqlite2 libexpat
@@ -214,7 +243,7 @@ ifneq ($(CONFIG_PACKAGE_php5-mod-gd),)
        --with-png-dir="$(STAGING_DIR)/usr" \
        --without-xpm-dir \
        --without-ttf \
-       --without-t1lib \
+       --without-t1lib \
        --enable-gd-native-ttf \
        --disable-gd-jis-conv
 else
@@ -251,12 +280,31 @@ ifneq ($(CONFIG_PACKAGE_php5-mod-sqlite),)
 else
   PKG_CONFIGURE_OPTS+= --without-sqlite
 endif
+ifneq ($(CONFIG_PACKAGE_php5-mod-pdo),)
+  PKG_CONFIGURE_OPTS+= --enable-pdo=shared
+  ifneq ($(CONFIG_PACKAGE_php5-mod-pdo-sqlite),)
+    PKG_CONFIGURE_OPTS+= --with-pdo-sqlite=shared,"$(STAGING_DIR)/usr"
+  endif
+else
+  PKG_CONFIGURE_OPTS+= --disable-pdo
+endif
 ifneq ($(CONFIG_PACKAGE_php5-mod-xml),)
   PKG_CONFIGURE_OPTS+= --enable-xml=shared,"$(STAGING_DIR)/usr" \
        --with-libexpat-dir="$(STAGING_DIR)/usr"
 else
   PKG_CONFIGURE_OPTS+= --disable-xml
 endif
+ifneq ($(CONFIG_PACKAGE_php5-mod-apc),)
+  PKG_CONFIGURE_OPTS+= --enable-apc --disable-apc-mmap --disable-apc-pthreadmutex
+  PKG_CONFIGURE_LIBS+= -lrt
+else
+  PKG_CONFIGURE_OPTS+= --disable-apc
+endif
+ifneq ($(CONFIG_PACKAGE_php5-mod-exif),)
+  PKG_CONFIGURE_OPTS+= --enable-exif
+else
+  PKG_CONFIGURE_OPTS+= --disable-exif
+endif
 
 define Build/Configure
 endef
@@ -295,13 +343,15 @@ ifneq ($(CONFIG_PACKAGE_php5-cgi),)
                php_cv_cc_rpath="no" \
        )
        $(MAKE) -C $(PKG_BUILD_DIR)
-       mv $(PKG_BUILD_DIR)/sapi/cgi/php $(PKG_BUILD_DIR)/php-cgi
+       mv $(PKG_BUILD_DIR)/sapi/cgi/php-cgi $(PKG_BUILD_DIR)/php-cgi
   endef
 endif
 
 ifneq ($(CONFIG_PACKAGE_php5-fastcgi),)
   define Build/Compile/php5-fastcgi
        -$(MAKE) -C $(PKG_BUILD_DIR) clean
+       rm $(PKG_BUILD_DIR)/configure
+       cd $(PKG_BUILD_DIR) && ./buildconf --force
        $(call Build/Configure/Default, \
                $(PKG_CONFIGURE_OPTS) \
                --disable-cli \
@@ -314,7 +364,7 @@ ifneq ($(CONFIG_PACKAGE_php5-fastcgi),)
                php_cv_cc_rpath="no" \
        )
        $(MAKE) -C $(PKG_BUILD_DIR)
-       mv $(PKG_BUILD_DIR)/sapi/cgi/php $(PKG_BUILD_DIR)/php-fastcgi
+       mv $(PKG_BUILD_DIR)/sapi/cgi/php-cgi $(PKG_BUILD_DIR)/php-fcgi
   endef
 endif
 
@@ -324,6 +374,10 @@ define Build/Compile
        $(call Build/Compile/php5-fastcgi)
 endef
 
+define Package/php5/conffiles
+/etc/php.ini
+endef
+
 define Package/php5/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/php.ini $(1)/etc/
@@ -331,17 +385,17 @@ endef
 
 define Package/php5-cli/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/php-cli $(1)/usr/bin/php
+       $(CP) $(PKG_BUILD_DIR)/php-cli $(1)/usr/bin/php-cli
 endef
 
 define Package/php5-cgi/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/php-cgi $(1)/usr/bin/php
+       $(CP) $(PKG_BUILD_DIR)/php-cgi $(1)/usr/bin/php-cgi
 endef
 
 define Package/php5-fastcgi/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/php-fastcgi $(1)/usr/sbin/php
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_BUILD_DIR)/php-fcgi $(1)/usr/bin/php-fcgi
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/php.init $(1)/etc/init.d/php
 endef
@@ -373,4 +427,8 @@ $(eval $(call BuildPlugin,php5-mod-pgsql,pgsql))
 $(eval $(call BuildPlugin,php5-mod-session,session))
 $(eval $(call BuildPlugin,php5-mod-sockets,sockets))
 $(eval $(call BuildPlugin,php5-mod-sqlite,sqlite))
+$(eval $(call BuildPlugin,php5-mod-pdo,pdo))
+$(eval $(call BuildPlugin,php5-mod-pdo-sqlite,pdo_sqlite))
 $(eval $(call BuildPlugin,php5-mod-xml,xml))
+$(eval $(call BuildPlugin,php5-mod-apc))
+$(eval $(call BuildPlugin,php5-mod-exif))