[packages] massive: use $(INSTALL_DIR) instead of 'mkdir -p' in install and InstallDev
[openwrt/svn-archive/archive.git] / lang / psycopg / Makefile
index 1f22b52bca65ff43fc87ad89b692ba699691bdf4..76166f3aef00826bfc0ff1030540b03bef5eac95 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -16,16 +15,21 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.initd.org/pub/software/psycopg/
 PKG_MD5SUM:=a31f79f68d6d32898d6f24e11369a106
 
-include $(INCLUDE_DIR)/package.mk
-include ../python/python-package.mk
+PKG_BUILD_DEPENDS:=python
 
-define PyPackage/python-psycopg
- TITLE:=PostgreSQL database adapter for Python
- URL:=http://www.initd.org/
- DEPENDS+= +libpq +python-egenix-mx
+include $(INCLUDE_DIR)/package.mk
+-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+
+define Package/python-psycopg
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=PostgreSQL database adapter for Python
+  URL:=http://www.initd.org/
+  DEPENDS:=+python-mini +libpq +python-egenix-mx
 endef
 
-define PyPackage/python-psycopg/description
+define Package/python-psycopg/description
  This package contains is a PostgreSQL database adapter for the Python 
  programming language.
 endef
@@ -35,8 +39,11 @@ CONFIGURE_ARGS += \
        --with-postgres-libraries="$(STAGING_DIR)/usr/lib" \
        --with-postgres-includes="$(STAGING_DIR)/usr/include" \
        --with-mxdatetime-includes="$(STAGING_DIR)$(PYTHON_PKG_DIR)/mx/DateTime/mxDateTime" \
+       --with-python-prefix=$(STAGING_DIR)/usr
+       --with-python-exec-prefix=$(STAGING_DIR)/usr
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                OPT="$(TARGET_CFLAGS)"
 endef
@@ -47,3 +54,4 @@ define PyPackage/python-psycopg/install
 endef
 
 $(eval $(call PyPackage,python-psycopg))
+$(eval $(call BuildPackage,python-psycopg))