Disable jbt6k74 mode setting. The kernel driver takes care of it now.
[openwrt/svn-archive/archive.git] / lang / psycopg / Makefile
index a1fdb491a251bb8d6e8abbcf0ac057cb7896d508..76166f3aef00826bfc0ff1030540b03bef5eac95 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,20 +14,19 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.initd.org/pub/software/psycopg/
 PKG_MD5SUM:=a31f79f68d6d32898d6f24e11369a106
+
 PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifeq ($(DUMP)$(Build/Compile/PyMod),)
-  $(error Python packaging code not found.)
-endif
 
 define Package/python-psycopg
+  SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=PostgreSQL database adapter for Python
   URL:=http://www.initd.org/
-  DEPENDS:=python-core +libpq +python-egenix-mx
+  DEPENDS:=+python-mini +libpq +python-egenix-mx
 endef
 
 define Package/python-psycopg/description
@@ -41,8 +39,11 @@ CONFIGURE_ARGS += \
        --with-postgres-libraries="$(STAGING_DIR)/usr/lib" \
        --with-postgres-includes="$(STAGING_DIR)/usr/include" \
        --with-mxdatetime-includes="$(STAGING_DIR)$(PYTHON_PKG_DIR)/mx/DateTime/mxDateTime" \
+       --with-python-prefix=$(STAGING_DIR)/usr
+       --with-python-exec-prefix=$(STAGING_DIR)/usr
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                OPT="$(TARGET_CFLAGS)"
 endef