Disable jbt6k74 mode setting. The kernel driver takes care of it now.
[openwrt/svn-archive/archive.git] / lang / psycopg / Makefile
index f4060568f6f642833b80fbdbf752edd4753491cc..76166f3aef00826bfc0ff1030540b03bef5eac95 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -27,7 +26,7 @@ define Package/python-psycopg
   CATEGORY:=Languages
   TITLE:=PostgreSQL database adapter for Python
   URL:=http://www.initd.org/
-  DEPENDS:=python-core +libpq +python-egenix-mx
+  DEPENDS:=+python-mini +libpq +python-egenix-mx
 endef
 
 define Package/python-psycopg/description
@@ -40,6 +39,8 @@ CONFIGURE_ARGS += \
        --with-postgres-libraries="$(STAGING_DIR)/usr/lib" \
        --with-postgres-includes="$(STAGING_DIR)/usr/include" \
        --with-mxdatetime-includes="$(STAGING_DIR)$(PYTHON_PKG_DIR)/mx/DateTime/mxDateTime" \
+       --with-python-prefix=$(STAGING_DIR)/usr
+       --with-python-exec-prefix=$(STAGING_DIR)/usr
 
 define Build/Compile
        $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)