Merge pull request #19372 from cotequeiroz/libgd
[feed/packages.git] / lang / python / python3 / Makefile
index 1d6c021db8406ddaafa0f86a5598dda09659fdc3..003653cc17c8b21674c01c4eb55480d2b698d074 100644 (file)
@@ -11,13 +11,12 @@ include $(TOPDIR)/rules.mk
 include ../python3-version.mk
 
 PKG_NAME:=python3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_VERSION:=$(PYTHON3_VERSION).$(PYTHON3_VERSION_MICRO)
 
 PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
-# FIXME: if updating, get rid of [1] & [2] asap
-PKG_HASH:=a7f1265b6e1a5de1ec5c3ec7019ab53413469934758311e9d240c46e5ae6e177
+PKG_HASH:=8437efd5b106ef0a75aabfbf23d880625120a73a86a22ade4d2e2e68d7b74486
 
 PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
 PKG_LICENSE:=PSF-2.0
@@ -206,14 +205,6 @@ define Build/Compile/python3-pip
                --root=$(PKG_BUILD_DIR)/install-pip \
                --prefix=/usr \
                $(PKG_BUILD_DIR)/Lib/ensurepip/_bundled/pip-$(PYTHON3_PIP_VERSION)-py3-none-any.whl
-       # FIXME: [1] get rid of this asap; 'patch' doesn't like Windows endings, and this file is full of them...
-       #        I actually tried this in a number of ways and the only way to fix this is to implement
-       #        a poor-man's dos2unix using sed.
-       #        The issue is with the pip package; it seems that it throws in some Windows line-endings
-       #        and 'patch' won't handle them. So, we do a "dos2unix" and then patch.
-       #        We can get rid of this once this is solved upstream and in pip:
-       #            https://github.com/pypa/pep517/pull/130
-       sed 's/\r//' -i $(PKG_BUILD_DIR)/install-pip/usr/lib/python$(PYTHON3_VERSION)/site-packages/pip/_vendor/pep517/in_process/__init__.py
        $(call PatchDir,$(PKG_BUILD_DIR)/install-pip/usr/lib/python$(PYTHON3_VERSION)/site-packages,./patches-pip,)
 endef
 else
@@ -336,14 +327,10 @@ HOST_MAKE_VARS += \
        USE_PYTHON_CONFIG_PY=1
 endif
 
-# FIXME: remove when removing patch '028-host-python-support-ssl-with-libressl.patch'
-HOST_CFLAGS += \
-       -DOPENWRT_HOST_BUILD
-
 HOST_CONFIGURE_ARGS+= \
        --enable-optimizations \
        --with-ensurepip=upgrade \
-       --with-system-expat=$(STAGING_DIR_HOSTPKG) \
+       --with-system-expat=$(STAGING_DIR_HOST) \
        --with-ssl-default-suites=openssl \
        --without-cxx-main \
        --without-pymalloc \
@@ -382,8 +369,6 @@ define Host/Install
                touch $(HOST_PYTHON3_PKG_DIR)/.setuptools_installed_$(PYTHON3_SETUPTOOLS_VERSION)-$(PYTHON3_SETUPTOOLS_PKG_RELEASE)
        )
        $(if $(wildcard $(HOST_PYTHON3_PKG_DIR)/.pip_installed_$(PYTHON3_PIP_VERSION)-$(PYTHON3_PIP_PKG_RELEASE)),,
-               # FIXME: [2] get rid of this asap; same as [1]
-               sed 's/\r//' -i $(HOST_PYTHON3_PKG_DIR)/pip/_vendor/pep517/in_process/__init__.py
                $(call HostPatchDir,$(HOST_PYTHON3_PKG_DIR),./patches-pip,)
                touch $(HOST_PYTHON3_PKG_DIR)/.pip_installed_$(PYTHON3_PIP_VERSION)-$(PYTHON3_PIP_PKG_RELEASE)
        )