Merge pull request #4853 from StevenHessing/noddos
[feed/packages.git] / lang / python / python3 / patches / 003-do-not-run-distutils-tests.patch
index 77c089f5f79f8e46557d7303645755b4c67996d0..7e7b252200f9373b64d25b5257556b379bd420d8 100644 (file)
@@ -1,10 +1,8 @@
-diff --git a/Makefile.pre.in b/Makefile.pre.in
-index ce2c0aa..b0c8322 100644
 --- a/Makefile.pre.in
 +++ b/Makefile.pre.in
-@@ -1256,41 +1256,6 @@ libinstall:     build_all $(srcdir)/Lib/$(PLATDIR) $(srcdir)/Modules/xxmodule.c
-               done; \
-       done
+@@ -1307,41 +1307,6 @@ libinstall:     build_all $(srcdir)/Modules/
+       $(INSTALL_DATA) `cat pybuilddir.txt`/_sysconfigdata_$(ABIFLAGS)_$(MACHDEP)_$(MULTIARCH).py \
+               $(DESTDIR)$(LIBDEST); \
        $(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
 -      if test -d $(DESTDIR)$(LIBDEST)/distutils/tests; then \
 -              $(INSTALL_DATA) $(srcdir)/Modules/xxmodule.c \
@@ -42,5 +40,5 @@ index ce2c0aa..b0c8322 100644
 -      -PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
 -              $(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/PatternGrammar.txt
  
- # Create the PLATDIR source directory, if one wasn't distributed..
- $(srcdir)/Lib/$(PLATDIR):
+ python-config: $(srcdir)/Misc/python-config.in Misc/python-config.sh
+       # Substitution happens here, as the completely-expanded BINDIR