Merge pull request #4853 from StevenHessing/noddos
[feed/packages.git] / lang / python / python3 / patches / 016-adjust-config-paths.patch
index fb709b7e4f1a8f173499908b194242386d6b4d3b..cca6e1ed77272da8d7a739603239029f6b494a2c 100644 (file)
@@ -1,8 +1,6 @@
-diff --git a/Lib/distutils/sysconfig.py b/Lib/distutils/sysconfig.py
-index 8bf1a70..c2708c3 100644
 --- a/Lib/distutils/sysconfig.py
 +++ b/Lib/distutils/sysconfig.py
-@@ -424,6 +424,7 @@ def _init_posix():
+@@ -421,6 +421,7 @@ def _init_posix():
          platform=sys.platform,
          multiarch=getattr(sys.implementation, '_multiarch', ''),
      ))
@@ -10,8 +8,6 @@ index 8bf1a70..c2708c3 100644
      _temp = __import__(name, globals(), locals(), ['build_time_vars'], 0)
      build_time_vars = _temp.build_time_vars
      global _config_vars
-diff --git a/Lib/sysconfig.py b/Lib/sysconfig.py
-index 9314e71..4861261 100644
 --- a/Lib/sysconfig.py
 +++ b/Lib/sysconfig.py
 @@ -343,6 +343,7 @@ def get_makefile_filename():
@@ -22,11 +18,9 @@ index 9314e71..4861261 100644
      return os.environ.get('_PYTHON_SYSCONFIGDATA_NAME',
          '_sysconfigdata_{abi}_{platform}_{multiarch}'.format(
          abi=sys.abiflags,
-diff --git a/Makefile.pre.in b/Makefile.pre.in
-index cd7d33d..ad6572f 100644
 --- a/Makefile.pre.in
 +++ b/Makefile.pre.in
-@@ -1301,7 +1301,7 @@ libinstall:      build_all $(srcdir)/Modules/xxmodule.c
+@@ -1304,7 +1304,7 @@ libinstall:      build_all $(srcdir)/Modules/
                        esac; \
                done; \
        done
@@ -34,8 +28,8 @@ index cd7d33d..ad6572f 100644
 +      $(INSTALL_DATA) `cat pybuilddir.txt`/_sysconfigdata*.py \
                $(DESTDIR)$(LIBDEST); \
        $(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
-       if test -d $(DESTDIR)$(LIBDEST)/distutils/tests; then \
-@@ -1436,7 +1436,7 @@ sharedinstall: sharedmods
+@@ -1404,7 +1404,7 @@ sharedinstall: sharedmods
                --install-scripts=$(BINDIR) \
                --install-platlib=$(DESTSHARED) \
                --root=$(DESTDIR)/
@@ -44,11 +38,9 @@ index cd7d33d..ad6572f 100644
        -rm -r $(DESTDIR)$(DESTSHARED)/__pycache__
  
  # Here are a couple of targets for MacOSX again, to install a full
-diff --git a/configure b/configure
-index cf95b27..8203fbb 100755
 --- a/configure
 +++ b/configure
-@@ -14895,7 +14895,7 @@ LDVERSION='$(VERSION)$(ABIFLAGS)'
+@@ -15005,7 +15005,7 @@ LDVERSION='$(VERSION)$(ABIFLAGS)'
  $as_echo "$LDVERSION" >&6; }
  
  
@@ -57,11 +49,9 @@ index cf95b27..8203fbb 100755
    LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}"
  else
    LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
-diff --git a/configure.ac b/configure.ac
-index 1d63813..25f25ed 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -4600,7 +4600,7 @@ AC_MSG_RESULT($LDVERSION)
+@@ -4656,7 +4656,7 @@ AC_MSG_RESULT($LDVERSION)
  
  dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
  AC_SUBST(PY_ENABLE_SHARED)