[package] update libcurl to 7.19.4
[openwrt/svn-archive/archive.git] / lang / telepathy-python / Makefile
index 853210a951daa9b39a5afd691d7c84598d2f1c9b..028505610c87f2e1eafa8a4fb960f7ff2b720e5f 100644 (file)
@@ -4,16 +4,19 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=telepathy-python
-PKG_VERSION:=0.15.0
+PKG_VERSION:=0.15.3
 PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://telepathy.freedesktop.org/releases/telepathy-python/
+PKG_MD5SUM:=594a66a70764052e30df9428b5be52b2
 
 include $(INCLUDE_DIR)/package.mk
+-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
 
 define Package/telepathy-python
   SUBMENU:=Python
@@ -21,20 +24,26 @@ define Package/telepathy-python
   CATEGORY:=Languages
   TITLE:=telepathy-python
   URL:=http://telepathy.freedesktop.org
-  DEPENDS:=python-core
+  DEPENDS:=+python-mini +dbus-python
 endef
 
 define Package/telepathy-python/description
-  telepathy- python bingings
+  telepathy python bindings
 endef
 
 define Build/Compile
-       cd $(PKG_BUILD_DIR) ; $(CONFIGURE_VARS) $(MAKE_VARS) /usr/bin/python ./setup.py install --prefix="$(PKG_INSTALL_DIR)/usr"
+       $(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
 endef
 
 define Package/telepathy-python/install
-       mkdir -p $(1)
-       cp -r $(PKG_INSTALL_DIR)/* $(1)
+       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
+       $(CP) \
+           $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
+           $(1)$(PYTHON_PKG_DIR)
 endef
 
 $(eval $(call BuildPackage,telepathy-python))
+
+$(eval $(call RequireCommand,xsltproc, \
+       $(PKG_NAME) requires xsltproc installed on the host-system. \
+))