[packages] libmms: Update to v0.6 (#8756)
[openwrt/svn-archive/archive.git] / libs / apr / Makefile
index a53570a11c1e28c538a3e4707aeb48545cbc1182..43f075036c5fe21d713ecfd930068ea080b9e200 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=apr
-PKG_VERSION:=1.2.9
-PKG_RELEASE:=2
+PKG_VERSION:=1.4.2
+PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://apache.d-s-s-p.de/apr/
-PKG_MD5SUM:=6f4b063ac01a54ba0818c31280f06959
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://www.ibiblio.org/pub/mirrors/apache/apr
+PKG_MD5SUM:=4b00e8f70c067893d075577962656b35
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=libtool
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -33,16 +35,14 @@ CONFIGURE_ARGS += \
        --disable-dso \
        --enable-ipv6
 
+# XXX: ac_cv_sizeof_struct_iovec=1 is just to trick configure
 CONFIGURE_VARS += \
+       ac_cv_sizeof_struct_iovec=1 \
        apr_cv_process_shared_works=no \
        apr_cv_mutex_robust_shared=no \
        apr_cv_tcp_nodelay_with_cork=yes \
        LDFLAGS="$$$$LDFLAGS -lpthread" \
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/include/apr-1 $(1)/usr/lib $(1)/usr/lib/pkgconfig $(1)/usr/share/build-1
        $(CP)   $(PKG_INSTALL_DIR)/usr/bin/apr-1-config \