[packages] Added posix library for Lua: lang/luaposix
[openwrt/svn-archive/archive.git] / libs / bluez-libs / Makefile
index adffcaf1f2420e346f91ce756c993d110703baa1..eda1f4dd53e054e28cff07198d7ed88e08156c92 100644 (file)
@@ -9,13 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bluez-libs
-PKG_VERSION:=2.24
+PKG_VERSION:=3.24
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://bluez.sourceforge.net/download
-PKG_MD5SUM:=d0ba50e251ae1e7f2c09024facde8e40
-PKG_CAT:=zcat
+PKG_MD5SUM:=3af3dfa6ff01715e91bdc985d71ee21e
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -43,19 +42,12 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include/bluetooth
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/bluetooth/*.h $(STAGING_DIR)/usr/include/bluetooth
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libbluetooth.{a,so*} $(STAGING_DIR)/usr/lib/
-       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/bluez.pc $(STAGING_DIR)/usr/lib/pkgconfig/
-endef
-
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/bluetooth \
-               $(STAGING_DIR)/usr/lib/libbluetooth.{a,so*} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/bluez.pc
+       mkdir -p $(1)/usr/include/bluetooth
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/bluetooth/*.h $(1)/usr/include/bluetooth
+       mkdir -p $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libbluetooth.{a,so*} $(1)/usr/lib/
+       mkdir -p $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/bluez.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/bluez-libs/install