[packages] xinetd: update to 2.3.15 (CVE-2012-0862), use CONFIGURE_{ARGS,VARS} &...
[openwrt/svn-archive/archive.git] / libs / curl / Makefile
index 411ee0599c025ac50926a7185eaba54beb0e6a50..ea1dcdec204839659a7c0d2cad7fc0c35ae32692 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.19.6
+PKG_VERSION:=7.23.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -19,9 +19,10 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
        ftp://ftp.planetmirror.com/pub/curl/ \
        http://www.mirrormonster.com/curl/download/ \
        http://curl.mirrors.cyberservers.net/download/
-PKG_MD5SUM:=8402c1f654c51ad7287aad57c3aa79be
+PKG_MD5SUM:=0296d3196b4bf82c896a869b38dbc5f2
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=libtool
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -33,6 +34,7 @@ endef
 
 define Package/curl
   $(call Package/curl/Default)
+  SUBMENU:=File Transfer
   DEPENDS:=+libcurl
   TITLE:=A client-side URL transfer utility
 endef
@@ -76,17 +78,14 @@ CONFIGURE_ARGS += \
        --without-nss \
        --without-libssh2 \
        --with-zlib="$(STAGING_DIR)/usr" \
+       $(call autoconf_bool,CONFIG_IPV6,ipv6) \
 
 CONFIGURE_VARS += \
        LDFLAGS="$$$$LDFLAGS -lcrypto -lssl -lz" \
        CC="$(filter-out ccache,$(TARGET_CC))"
 
-define Build/Configure
-       $(call Build/Configure/Default,,bash)
-endef
-
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
+       $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                CC="$(TARGET_CC)" \
                install
@@ -99,7 +98,7 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcurl.{a,so*} $(1)/usr/lib/
        $(CP) $(PKG_BUILD_DIR)/libcurl.pc $(1)/usr/lib/pkgconfig/
        $(SED) 's,-L$$$${exec_prefix}/lib,,g' $(1)/usr/bin/curl-config
-       $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/libcurl.pc
+       [ -n "$(TARGET_LDFLAGS)" ] && $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/libcurl.pc || true
        ln -sf $(STAGING_DIR)/usr/bin/curl-config $(2)/bin/
 endef