[package] add elfutils
[openwrt/svn-archive/archive.git] / libs / cyassl / Makefile
index f672a0af9347c3431824316bb60af2b41f30d13f..ff84535118db30ba0ddbab35d82915b4e0601b93 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2008 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,49 +8,48 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cyassl
-PKG_VERSION:=1.0.3
+PKG_VERSION:=1.4.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
 PKG_SOURCE_URL:=http://www.yassl.com/
-PKG_MD5SUM:=e9e85a2d78cd535a049e4acce786e42d
+PKG_MD5SUM:=037397c7df84b9a12e614bf46135df1c
 
-include $(INCLUDE_DIR)/package.mk
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
-define Package/cyassl/Default
-  TITLE:=CyaSSL
-  URL:=http://www.yassl.com/
-endef
+include $(INCLUDE_DIR)/package.mk
 
 define Package/libcyassl
-  $(call Package/cyassl/Default)
   SECTION:=libs
+  SUBMENU:=SSL
   CATEGORY:=Libraries
   DEPENDS:=+zlib
-  TITLE+= (library)
+  TITLE:=CyaSSL library
+  URL:=http://www.yassl.com/
 endef
 
 define Package/libcyassl/description
-       CyaSSL is an SSL library optimized for small footprint, both on disk and for memory use.
+CyaSSL is an SSL library optimized for small footprint, both on disk and for
+memory use.
 endef
 
 TARGET_CFLAGS += $(FPIC)
 
 CONFIGURE_ARGS += \
-       --with-zlib="$(STAGING_DIR)/usr"
+       --with-libz="$(STAGING_DIR)/usr"
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include/ctaocrypt
-       $(CP) $(PKG_BUILD_DIR)/ctaocrypt/include/*.h $(1)/usr/include/ctaocrypt
-       
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/src/.libs/libcyassl.{a,so*} $(1)/usr/lib/
-       $(CP) $(PKG_BUILD_DIR)/src/libcyassl.la $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcyassl.{a,so*,la} $(1)/usr/lib/
 endef
 
 define Package/libcyassl/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/src/.libs/libcyassl.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcyassl.so* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libcyassl))