Merge pull request #4853 from StevenHessing/noddos
[feed/packages.git] / libs / db47 / Makefile
index 0265eb0f58d5c9dd08499fd90d4f4be25f0c2604..7f642abd95a4322a535f26c5349602ac3271f8bd 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2012 OpenWrt.org
+# Copyright (C) 2009-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,16 +8,19 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/uclibc++.mk
 
+BASE_VERSION:=4.7.25
+
 PKG_NAME:=db47
-PKG_VERSION:=4.7.25.NC
-PKG_RELEASE:=6
+PKG_VERSION:=$(BASE_VERSION).4.NC
+PKG_RELEASE:=5
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/db-$(PKG_VERSION)
-PKG_SOURCE:=db-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/db-$(BASE_VERSION).NC
+PKG_SOURCE:=db-$(BASE_VERSION).NC.tar.gz
 PKG_SOURCE_URL:=http://download.oracle.com/berkeley-db/
-PKG_MD5SUM:=073ab7f20d24b3872a51ca762f5090e7
+PKG_HASH:=cd39c711023ff44c01d3c8ff0323eef7318660772b24f287556e6bf676a12535
 
-PKG_LICENSE:=BSD-2c
+PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
+PKG_LICENSE:=Sleepycat
 PKG_LICENSE_FILES:=LICENSE
 
 PKG_FIXUP:=autoreconf
@@ -31,8 +34,8 @@ define Package/libdb47
   CATEGORY:=Libraries
   DEPENDS:=+libxml2
   TITLE:=Berkeley DB library (4.7)
-  URL:=http://www.sleepycat.com/products/db.shtml
-  MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+  URL:=http://www.oracle.com/us/products/database/berkeley-db
+  PROVIDES:=libdb47-full
 endef
 
 define Package/libdb47/description
@@ -44,8 +47,8 @@ define Package/libdb47xx
   CATEGORY:=Libraries
   DEPENDS:=+libdb47 $(CXX_DEPENDS)
   TITLE:=Berkeley DB library (4.7) for C++
-  URL:=http://www.sleepycat.com/products/db.shtml
-  MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+  URL:=http://www.oracle.com/us/products/database/berkeley-db
+  PROVIDES:=libdb47xx-full
 endef
 
 define Package/libdb47xx/description
@@ -59,13 +62,11 @@ CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
        --disable-java \
-       --with-mutex=UNIX/fcntl \
+       --with-mutex=POSIX/pthreads/library \
        --disable-tcl \
        --disable-rpc \
        --enable-compat185 \
-       --enable-smallbuild \
        --disable-debug \
-       --enable-cryptography \
        $(if $(CONFIG_PACKAGE_libdb47xx),--enable-cxx,--disable-cxx)
 
 TARGET_CFLAGS += $(FPIC)
@@ -97,4 +98,3 @@ endef
 
 $(eval $(call BuildPackage,libdb47))
 $(eval $(call BuildPackage,libdb47xx))
-