Merge pull request #19372 from cotequeiroz/libgd
[feed/packages.git] / libs / expat / Makefile
index 0f169e515823956db63d6f5ccfc0feb2a1528526..78c417cfa25334a515a43f8da4839fb9e5b1f66b 100644 (file)
@@ -6,12 +6,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=expat
-PKG_VERSION:=2.4.1
+PKG_VERSION:=2.4.9
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@SF/expat
-PKG_HASH:=cf032d0dba9b928636548e32b327a2d66b1aab63c4f4a13dd132c2d1d2f2fb6a
+PKG_HASH:=6e8c0728fe5c7cd3f93a6acce43046c5e4736c7b4b68e032e9350daa0efc0354
 
 PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
 PKG_LICENSE:=MIT
@@ -20,9 +20,8 @@ PKG_CPE_ID:=cpe:/a:libexpat:expat
 
 CMAKE_INSTALL:=1
 
-include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
-include ../../devel/ninja/ninja-cmake.mk
+include $(INCLUDE_DIR)/cmake.mk
 
 define Package/libexpat
   SECTION:=libs
@@ -35,7 +34,7 @@ define Package/libexpat/description
  A fast, non-validating, stream-oriented XML parsing library.
 endef
 
-OPTIONS += \
+CMAKE_OPTIONS += \
        -DDOCBOOK_TO_MAN=OFF \
        -DEXPAT_BUILD_TOOLS=OFF \
        -DEXPAT_BUILD_EXAMPLES=OFF \
@@ -47,13 +46,9 @@ OPTIONS += \
        -DEXPAT_NS=OFF \
        -DEXPAT_DEV_URANDOM=OFF
 
-CMAKE_OPTIONS += $(OPTIONS)
-CMAKE_HOST_OPTIONS += $(OPTIONS)
-
 define Package/libexpat/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libexpat.so.* $(1)/usr/lib/
 endef
 
-$(eval $(call HostBuild))
 $(eval $(call BuildPackage,libexpat))