[net] File Transfer: Moved old FTP category and combined with other file transfer...
[openwrt/svn-archive/archive.git] / libs / file / Makefile
index 3192591b9ed66d2b8bb1eee75002ed6ddb95578f..7c16ea16dbc820a60632ceebd36a3e128349fd10 100644 (file)
@@ -1,80 +1,87 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=file
-PKG_VERSION:=4.19
-PKG_RELEASE:=1
+PKG_VERSION:=4.26
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.astron.com/pub/file/
-PKG_MD5SUM:=a61ef3aa8339d5987148089afde25f60
+PKG_MD5SUM:=74cd5466416136da30a4e69f74dbc7a0
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/libmagic
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS:=+zlib
-  TITLE:=Determines file type using "magic" numbers
+define Package/file/Default
+  TITLE:=File type determination
   URL:=ftp://ftp.astron.com/pub/file/
 endef
 
 define Package/file
+$(call package/file/Default)
   SECTION:=utils
   CATEGORY:=Utilities
+  TITLE+= utility
   DEPENDS:=+libmagic
-  TITLE:=Determines file type using "magic" numbers
-  URL:=ftp://ftp.astron.com/pub/file/
 endef
 
-define Package/file/description
- File tests each argument in an attempt to classify it. There
- are three sets of tests, performed in this order: filesystem
- tests, magic number tests, and language tests. The first test
- that succeeds causes the file type to be printed.
-
- Starting with version 4, the file command is not much more than
- a wrapper around the "magic" library. 
+define Package/libmagic
+$(call package/file/Default)
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE+= library
+  DEPENDS:=+zlib
 endef
 
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
-       --disable-rpath \
-       --without-libiconv-prefix \
-       --without-libintl-prefix \
 
-MAKE_FLAGS += \
-       -C $(PKG_BUILD_DIR)/src \
-       DESTDIR="$(PKG_INSTALL_DIR)" \
-       all install \
+MAKE_PATH := src
 
-define Build/InstallDev
-       mkdir -p $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/magic.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmagic.{a,so*} $(1)/usr/lib/
+TARGET_CFLAGS += $(FPIC)
+
+define Build/Compile/magic
+       ( cd $(PKG_BUILD_DIR)/magic/Magdir; \
+               for f in `ls`; do \
+                       cat $$$${f}; \
+               done \
+       ) > $(PKG_BUILD_DIR)/magic/magic
 endef
+Hooks/Compile/Post += Build/Compile/magic
 
-define Package/libmagic/install
+define Build/Install/magic
+       $(INSTALL_DIR) $(PKG_INSTALL_DIR)/usr/share/file
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/magic/magic $(PKG_INSTALL_DIR)/usr/share/file/
+endef
+Hooks/Install/Post += Build/Install/magic
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/magic.h $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmagic.so.* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmagic.{a,so*} $(1)/usr/lib/
 endef
 
 define Package/file/install
        $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/file $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/share/file
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/file $(1)/usr/bin
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/magic/Magdir/linux $(1)/usr/share/file/magic
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/magic/magic.mime $(1)/usr/share/file/magic.mime
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/file/magic $(1)/usr/share/file/
+endef
+
+define Package/libmagic/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmagic.so.* $(1)/usr/lib/
 endef
 
-$(eval $(call BuildPackage,libmagic))
 $(eval $(call BuildPackage,file))
+$(eval $(call BuildPackage,libmagic))