[package] fix lzo parallel build, patch from Raphael Huck
[openwrt/svn-archive/archive.git] / libs / gdbm / Makefile
index f86743bc1e8842d1c8e9f53e6ab2a8078aac1eb5..751f22a288443e2c5ef6d9892da7379a7371e678 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -27,6 +26,8 @@ define Package/libgdbm
   URL:=http://www.gnu.org/software/gdbm/
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
@@ -40,9 +41,9 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/gdbm.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgdbm.{a,so*} $(1)/usr/lib/
 endef