gettext: add support for using the stub headers on the host
[openwrt/svn-archive/archive.git] / libs / gettext / Makefile
index 12a3bfc60009916bb95623c1ad87b3e9eb770f15..c4b166f9ea8b506a328285cbd529508b51504730 100644 (file)
@@ -11,6 +11,7 @@ PKG_NAME:=gettext
 PKG_RELEASE:=2
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
 
 define Package/libintl
   SECTION:=libs
@@ -37,9 +38,26 @@ define Build/InstallDev
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/m4/* $(1)/usr/share/aclocal/
 endef
 
+define Host/Prepare
+       mkdir -p $(HOST_BUILD_DIR)
+endef
+
+define Host/Compile
+
+endef
+
+define Host/Install
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/include
+       $(INSTALL_DATA) ./src/include/libintl.h $(STAGING_DIR_HOST)/include/
+
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/aclocal
+       $(INSTALL_DATA) ./src/m4/* $(STAGING_DIR_HOST)/share/aclocal/
+endef
+
 define Package/libintl/install
        $(INSTALL_DIR) $(1)/tmp
        touch $(1)/tmp/.libintl-placeholder
 endef
 
+$(eval $(call HostBuild))
 $(eval $(call BuildPackage,libintl))