update asterisk-1.6.x to 1.6.2.0-beta2
[openwrt/svn-archive/archive.git] / libs / glib / Makefile
index ffe47b88ecb4d0e9f9455a4f7a74088966a305cf..b79173707b30482da9dd06e33a38917f144f84b7 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -36,6 +35,8 @@ define Package/glib1/description
  as trees, hashes, and lists.
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
@@ -56,6 +57,7 @@ CONFIGURE_VARS += \
        glib_cv_sizeof_gmutex=24 \
        glib_cv_byte_contents_gmutex="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0" \
 
+TARGET_LDFLAGS += -L$(TOOLCHAIN_DIR)/lib
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
 endef