glib2: update to 2.49.7
[feed/packages.git] / libs / glib2 / Makefile
index b1ad841488f427a0bfc2a532180755d4a6547921..013e23b1608d8d90e32897014e338b49495330e0 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2015 OpenWrt.org
+# Copyright (C) 2007-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=glib2
-PKG_VERSION:=2.44.1
+PKG_VERSION:=2.49.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=glib-$(PKG_VERSION).tar.xz
 PKG_BUILD_DIR:=$(BUILD_DIR)/glib-$(PKG_VERSION)
-PKG_SOURCE_URL:=@GNOME/glib/2.44
-PKG_MD5SUM:=83efba4722a9674b97437d1d99af79db
+PKG_SOURCE_URL:=@GNOME/glib/2.49
+PKG_MD5SUM:=397ead3fcf325cb921d54e2c9e7dfd7a
 
 PKG_BUILD_PARALLEL:=1
 HOST_BUILD_PARALLEL:=1
@@ -46,7 +46,8 @@ endef
 
 HOST_CONFIGURE_ARGS += \
        --disable-selinux \
-       --with-libiconv=gnu
+       --with-libiconv=gnu \
+       --with-pcre=internal
 
 CONFIGURE_ARGS += \
        --enable-shared \
@@ -54,7 +55,8 @@ CONFIGURE_ARGS += \
        --enable-debug=no \
        --disable-selinux \
        --disable-fam \
-       --with-libiconv=gnu
+       --with-libiconv=gnu \
+       --with-pcre=internal
 
 CONFIGURE_VARS += \
        glib_cv_stack_grows=no \