glib2: update to 2.49.7
[feed/packages.git] / libs / glib2 / Makefile
index d8500e6382d2a63ef27b5be47b5b48ef53879b8d..013e23b1608d8d90e32897014e338b49495330e0 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2015 OpenWrt.org
+# Copyright (C) 2007-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,18 +8,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=glib2
-PKG_VERSION:=2.44.1
+PKG_VERSION:=2.49.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=glib-$(PKG_VERSION).tar.xz
 PKG_BUILD_DIR:=$(BUILD_DIR)/glib-$(PKG_VERSION)
-PKG_SOURCE_URL:=@GNOME/glib/2.44
-PKG_MD5SUM:=83efba4722a9674b97437d1d99af79db
+PKG_SOURCE_URL:=@GNOME/glib/2.49
+PKG_MD5SUM:=397ead3fcf325cb921d54e2c9e7dfd7a
 
 PKG_BUILD_PARALLEL:=1
 HOST_BUILD_PARALLEL:=1
 PKG_BUILD_DEPENDS:=glib2/host libpthread zlib libintl libffi
-HOST_BUILD_DEPENDS:=libintl/host libiconv/host libffi/host
+HOST_BUILD_DEPENDS:=gettext-full/host libiconv/host libffi/host
 PKG_INSTALL:=1
 PKG_USE_MIPS16:=0
 
@@ -45,7 +45,9 @@ define Package/glib2/description
 endef
 
 HOST_CONFIGURE_ARGS += \
-       --disable-selinux
+       --disable-selinux \
+       --with-libiconv=gnu \
+       --with-pcre=internal
 
 CONFIGURE_ARGS += \
        --enable-shared \
@@ -53,12 +55,13 @@ CONFIGURE_ARGS += \
        --enable-debug=no \
        --disable-selinux \
        --disable-fam \
-       $(if $(ICONV_FULL),--with-libiconv=gnu)
+       --with-libiconv=gnu \
+       --with-pcre=internal
 
 CONFIGURE_VARS += \
        glib_cv_stack_grows=no \
        glib_cv_uscore=no \
-       ac_cv_path_GLIB_GENMARSHAL=$(STAGING_DIR_HOST)/bin/glib-genmarshal \
+       ac_cv_path_GLIB_GENMARSHAL=$(STAGING_DIR)/host/bin/glib-genmarshal \
        ac_cv_func_mmap_fixed_mapped=yes \
        ac_cv_func_posix_getpwuid_r=yes \
        ac_cv_func_posix_getgrgid_r=yes