glib2: update to 2.78.4
[feed/packages.git] / libs / glib2 / patches / 010-pcre.patch
index 87b32e73e97e44c35b839c2d5c5dc2767d543aba..ead8f7f2335466f42b7ec0d0507f3c64a65c6729 100644 (file)
@@ -1,10 +1,10 @@
 --- a/glib/meson.build
 +++ b/glib/meson.build
-@@ -365,6 +365,7 @@ pcre2_static_args = []
+@@ -402,6 +402,7 @@ pcre2_static_args = []
  
  if use_pcre2_static_flag
    pcre2_static_args = ['-DPCRE2_STATIC']
 +  pcre2 = pcre2.as_link_whole()
  endif
  
- glib_c_args = ['-DG_LOG_DOMAIN="GLib"', '-DGLIB_COMPILATION'] + pcre2_static_args + glib_hidden_visibility_args
+ glib_c_args = ['-DG_LOG_DOMAIN="GLib"'] + glib_c_args_internal + pcre2_static_args