i2c-tools: make the python dependency optional
[openwrt/svn-archive/archive.git] / libs / howl / Makefile
index 961760ab11b439d2e7d98636a3dd6dc33858f6b2..459f83834f93e8eaafebfd5250841632c19d5490 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +9,18 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=howl
 PKG_VERSION:=1.0.0
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.porchdogsoft.com/download/
 PKG_MD5SUM:=c389d3ffba0e69a179de2ec650f1fdcc
 
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
+TARGET_CFLAGS += $(FPIC)
+
 define Package/howl/Default
   SECTION:=net
   CATEGORY:=Network
@@ -38,6 +42,7 @@ endef
 
 define Package/howl-autoipd
   $(call Package/howl/Default)
+  SUBMENU:=IP Addresses and Names
   DEPENDS:=+libhowl
   TITLE:=An IPv4 Link-Local address self-assigner daemon
 endef
@@ -49,6 +54,7 @@ endef
 
 define Package/howl-mdnsresponder
   $(call Package/howl/Default)
+  SUBMENU:=IP Addresses and Names
   DEPENDS:=+libhowl +libpthread
   TITLE:=An mDNS (Multicast DNS) service responder daemon
 endef
@@ -64,6 +70,7 @@ endef
 
 define Package/howl-nifd
   $(call Package/howl/Default)
+  SUBMENU:=IP Addresses and Names
   DEPENDS:=+libhowl
   TITLE:=A network interface monitor daemon
 endef
@@ -74,6 +81,7 @@ endef
 
 define Package/howl-utils
   $(call Package/howl/Default)
+  SUBMENU:=IP Addresses and Names
   DEPENDS:=+libhowl
   TITLE+= (utilities)
 endef
@@ -89,14 +97,6 @@ define Build/Configure
        );
 endef
 
-TARGET_CFLAGS += $(FPIC)
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/howl $(1)/usr/include/