Merge pull request #4853 from StevenHessing/noddos
[feed/packages.git] / libs / libaudiofile / Makefile
index ba3a2afe2d6dd942e1b8d52bc218a2a9ae1b5b1c..41754463484a5337d2d71e28be00b4e24c19b5a3 100644 (file)
@@ -1,6 +1,4 @@
 #
-# Copyright (C) 2006-2016 OpenWrt.org
-#
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
@@ -9,11 +7,12 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=audiofile
 PKG_VERSION:=0.3.6
-PKG_RELEASE:=3
+PKG_RELEASE:=4
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@GNOME/$(PKG_NAME)/0.3
+PKG_HASH:=ea2449ad3f201ec590d811db9da6d02ffc5e87a677d06b92ab15363d8cb59782
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://audiofile.68k.org/
-PKG_MD5SUM:=2731d79bec0acef3d30d2fc86b0b72fd
 PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
 
 PKG_FIXUP:=autoreconf
@@ -38,8 +37,10 @@ endef
 CONFIGURE_ARGS+= \
        --enable-shared \
        --enable-static \
-       --disable-examples \
-       --with-build-cc="$(HOSTCC)" \
+       --disable-docs \
+       --disable-coverage \
+       --disable-examples
+
 
 TARGET_CFLAGS+= $(FPIC)