Update ethtool to version 6 (#3620)
[openwrt/svn-archive/archive.git] / libs / libdaemon / Makefile
index d6e8b4d707ecba025572938da03267edbcf40419..81b079745a199b35d6ab0497659b0bb3740383d6 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -9,13 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libdaemon
-PKG_VERSION:=0.10
+PKG_VERSION:=0.12
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://0pointer.de/lennart/projects/libdaemon/
-PKG_MD5SUM:=6812a5e4063b5016f25e9a0cebbd3dd9
-PKG_CAT:=zcat
+PKG_MD5SUM:=76596823cc1a6d1cdf7779b782ff0ee6
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -26,20 +25,22 @@ define Package/libdaemon
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=A lightweight C library that eases the writing of UNIX daemons
-  DESCRIPTION:=\
-       libdaemon is a lightweight C library that eases the writing of UNIX daemons.\\\
-       It consists of the following parts:\\\
-       - A wrapper around fork() which does the correct daemonization procedure of a process\\\
-       - A wrapper around syslog() for simpler and compatible log output to Syslog or STDERR\\\
-       - An API for writing PID files\\\
-       - An API for serializing UNIX signals into a pipe for usage with select() or poll()\\\
-       - An API for running subprocesses with STDOUT and STDERR redirected to syslog\\\
-       \\\
-       APIs like these are used in most daemon software available. It is not that \\\
-       simple to get it done right and code duplication is not a goal.
   URL:=http://0pointer.de/lennart/projects/libdaemon/
 endef
 
+define Package/libdaemon/description
+       libdaemon is a lightweight C library that eases the writing of UNIX daemons.
+       It consists of the following parts:
+       - A wrapper around fork() which does the correct daemonization procedure of a process
+       - A wrapper around syslog() for simpler and compatible log output to Syslog or STDERR
+       - An API for writing PID files
+       - An API for serializing UNIX signals into a pipe for usage with select() or poll()
+       - An API for running subprocesses with STDOUT and STDERR redirected to syslog
+
+       APIs like these are used in most daemon software available. It is not that
+       simple to get it done right and code duplication is not a goal.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
@@ -64,14 +65,6 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libdaemon.pc $(1)/usr/lib/pkgconfig/
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/libdaemon \
-               $(STAGING_DIR)/usr/lib/libdaemon.a \
-               $(STAGING_DIR)/usr/lib/libdaemon.so* \
-               $(STAGING_DIR)/usr/lib/pkgconfig/libdaemon.pc
-endef
-
 define Package/libdaemon/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdaemon.so.* $(1)/usr/lib/