cleanup Makefile and use now the OpenWrt way of building host tools
[openwrt/svn-archive/archive.git] / libs / libelf / Makefile
index 1404ccc834e888d771d7756f7fec211ad40860cd..88c0742bd70fb228f8a6e72dde1d6fbf280fe8ea 100644 (file)
@@ -4,17 +4,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libelf
-PKG_VERSION:=0.8.8
+PKG_VERSION:=0.8.10
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.mr511.de/software/
-PKG_MD5SUM:=be84e553686dd50c8b6d520f86f46521
+PKG_MD5SUM:=9db4d36c283d9790d8fa7df1f4d7b4d9
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,6 +24,8 @@ define Package/libelf
   URL:=http://www.stud.uni-hannover.de/~michael/software/
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
@@ -52,12 +53,6 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libelf.pc $(1)/usr/lib/pkgconfig/
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/libelf* \
-               $(STAGING_DIR)/usr/lib/libelf.{a,so*}
-endef
-
 define Package/libelf/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libelf.so.* $(1)/usr/lib/