Change the name to match patch convention
[openwrt/svn-archive/archive.git] / libs / libgphoto2 / Makefile
index 227f0e688309c19fee9e24aeaf34f62ef282cadc..2557c5538aa7556b916af77f349340d0051aac26 100644 (file)
@@ -4,7 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -31,7 +31,7 @@ endef
 
 define Package/libgphoto2
   $(call Package/libgphoto2/Default)
-  DEPENDS:=+libusb +libexif +libjpeg +libpthread
+  DEPENDS:=+libusb +libexif +libjpeg +libpthread +libltdl
   TITLE:=The basic library of the gphoto2 program.
   MENU:=1
 endef
@@ -42,17 +42,11 @@ define Package/libgphoto2-drivers
   TITLE:=Gphoto2 drivers for various cameras
 endef
 
-BIG_ENDIAN:=no
-ifeq ($(CONFIG_BIG_ENDIAN),y)
-  BIG_ENDIAN:=yes
-endif
-
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
                --enable-static \
                --disable-rpath \
-               --with-gnu-ld \
                --with-drivers=all \
                --without-included-ltdl \
                --without-libiconv-prefix \
@@ -63,8 +57,6 @@ define Build/Configure
                LIBUSB_CFLAGS="$$$$CPPFLAGS" \
                LIBUSB_LIBS="$$$$LDFLAGS -lusb" \
                LIBS="-lltdl" \
-               ac_cv_c_gettext_without_libintl=yes \
-               ac_cv_c_bigendian=$(BIG_ENDIAN) \
        )
 endef
 
@@ -92,19 +84,20 @@ define Build/InstallDev
 endef
 
 define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/bin/gphoto2-config \
+       rm -rf \
+               $(STAGING_DIR)/usr/bin/gphoto2-config \
                $(STAGING_DIR)/usr/bin/gphoto2-port-config \
                $(STAGING_DIR)/usr/include/gphoto2* \
                $(STAGING_DIR)/usr/lib/libgphoto*.{a,so*}
 endef
 
 define Package/libgphoto2/install
-       install -m0755 -d $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgphoto2{,_port}.so.* $(1)/usr/lib/
 endef
 
 define Package/libgphoto2-drivers/install
-       install -d -m0755 $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgphoto2{,_port} $(1)/usr/lib/
        rm -rf $(1)/usr/lib/libgphoto2{,_port}/*/*.{,l}a
 endef