[package] update xmlrpc-c to 1.19.2 (#5674)
[openwrt/svn-archive/archive.git] / libs / libid3tag / Makefile
index 1a352770b723cb13191ceacfd4215e491aa1d315..e15313144056b8ee24c3a8acadf5659d9bc6e891 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,10 +14,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/mad
 PKG_MD5SUM:=e5808ad997ba32c498803822078748c3
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,12 +22,16 @@ define Package/libid3tag
   CATEGORY:=Libraries
   DEPENDS:=+zlib
   TITLE:=An ID3 tag manipulation library
-  DESCRIPTION:=\
-       libid3tag is a library for reading and (eventually) writing ID3 tags, both \\\
-       ID3v1 and the various versions of ID3v2.
   URL:=http://mad.sourceforge.net/
 endef
 
+define Package/libid3tag/description
+       libid3tag is a library for reading and (eventually) writing ID3 tags, both 
+       ID3v1 and the various versions of ID3v2.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
@@ -55,12 +54,6 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libid3tag.{a,so*} $(1)/usr/lib/
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/id3tag.h \
-               $(STAGING_DIR)/usr/lib/libid3tag.{a,so*}
-endef
-
 define Package/libid3tag/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libid3tag.so.* $(1)/usr/lib/