[packages] add libmpeg2 (closes: #8317, thanks to W. Michael Petullo)
[openwrt/svn-archive/archive.git] / libs / libpar2 / Makefile
index 841d13a1e4e7d2646143bf67d3d2c4e3288c1e14..fb92ac117a5cef8fe2d95a296b05e518e1ce4b96 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -16,6 +16,7 @@ PKG_SOURCE_URL:=@SF/parchive
 PKG_MD5SUM:=94c6df4e38efe08056ecde2a04e0be91
 
 PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -24,6 +25,7 @@ define Package/libpar2
   CATEGORY:=Libraries
   DEPENDS:=+libsigcxx
   TITLE:=A library for performing common tasks related to PAR recovery sets
+  URL:=http://parchive.sourceforge.net/
 endef
 
 define Package/libpar2/description
@@ -34,14 +36,6 @@ CONFIGURE_ARGS += \
        --disable-static \
        --disable-nls \
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/libpar2
        $(INSTALL_DATA) \