[packages] file: bump version to 5.11
[openwrt/svn-archive/archive.git] / libs / libsdl / Makefile
index 85cc84aee7fba2ac6983e45dd4b7cd9f40184017..3356e945494c373e095705349fbb527aa6c3bc55 100644 (file)
@@ -9,13 +9,13 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=SDL
 PKG_VERSION:=1.2.14
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.libsdl.org/release/
 PKG_MD5SUM:=e52086d1b508fa0b76c52ee30b55bec4
 
-PKG_FIXUP:=libtool
+PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
 PKG_CONFIG_DEPENDS:=CONFIG_AUDIO_SUPPORT
@@ -27,7 +27,7 @@ define Package/libsdl
   CATEGORY:=Libraries
   TITLE:=Simple DirectMedia Layer
   URL:=http://www.libsdl.org
-  DEPENDS:=+DirectFB +zlib +libpthread +AUDIO_SUPPORT:alsa-lib
+  DEPENDS:=+directfb +zlib +libpthread +AUDIO_SUPPORT:alsa-lib
 endef
 
 define Package/libsdl/description
@@ -79,7 +79,7 @@ CONFIGURE_ARGS+= \
        --disable-video-photon \
        --disable-video-carbon \
        --disable-video-cocoa \
-       --disable-video-fbcon \
+       --enable-video-fbcon \
        --enable-video-directfb \
        --disable-video-ps2gs \
        --disable-video-ps3 \