[packages] rtorrent: update to r1123 (#6624)
[openwrt/svn-archive/archive.git] / libs / libshout / Makefile
index 285f3a827c375af166c2ea19d476165e3556fa51..a3ac2ffae8b811fde08b0d5e5f4fb88723f5316d 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -39,7 +38,7 @@ endef
 define Build/Configure
        $(call Build/Configure/Default, \
                VORBIS_CFLAGS="-I$(STAGING_DIR)/usr/include/tremor/"\
-               VORBIS_LIBS="-L$(STAGING_DIR)/usr/lib" \
+               VORBIS_LIBS="$(TARGET_LDFLAGS)" \
                --enable-shared \
                --enable-static \
        )
@@ -54,11 +53,13 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include/shout
+       $(INSTALL_DIR) $(1)/usr/include/shout
        $(CP) $(PKG_INSTALL_DIR)/usr/include/shout/shout.h $(1)/usr/include/shout
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libshout.{a,so*} $(1)/usr/lib/
-       mkdir -p $(1)/usr/lib/pkgconfig
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(SED) 's|/usr/include|$(STAGING_DIR)/usr/include|' \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/shout.pc
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/shout.pc $(1)/usr/lib/pkgconfig/             
 endef