[backfire/packages] ffmpeg: fix build failure on x86 (closes: #8840), install libswsc...
[openwrt/svn-archive/archive.git] / libs / libsigc++ / Makefile
index d91dfd24d2f27e9826aef8cfed94f2ef228fd99a..45d101ce7a0665e2b64d0da3c06228015bbbd7d8 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2008 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libsigc++
-PKG_VERSION:=2.2.4.2
-PKG_RELEASE:=2
+PKG_VERSION:=2.2.8
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@GNOME/libsigc++/2.2
-PKG_MD5SUM:=545edbb7b54eec4f723323d3158c0e0c
+PKG_MD5SUM:=1198425eab9fd605721a278c651b8dd8
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -23,13 +24,13 @@ define Package/libsigcxx
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=typesafe callback system for standard C++
-  URL:=http://libsigc++.sourceforge.net/
+  URL:=http://libsigc.sourceforge.net/
   DEPENDS:=+libstdcpp
 endef
 
 define Package/libsigcxx/description
- It allows you to define signals and to connect those signals to any 
- callback function, either global or a member function, regardless of 
+ It allows you to define signals and to connect those signals to any
+ callback function, either global or a member function, regardless of
  whether it is static or virtual.
 endef
 
@@ -42,12 +43,6 @@ CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/sigc++-2.0 $(1)/usr/include/
@@ -64,4 +59,3 @@ define Package/libsigcxx/install
 endef
 
 $(eval $(call BuildPackage,libsigcxx))
-