[packages] add new package shflags
[openwrt/svn-archive/archive.git] / libs / libspe2 / Makefile
index e68b9f5aa6f9896b87a7119729858ecdedf86da1..2fc4aa421f5206aaf6b8e273ca909eb6c751558e 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -23,7 +22,7 @@ define Package/libspe2
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=SPE Runtime Management Library for the Cell Broadband Engine
-  DEPENDS:=@TARGET_ps3
+  DEPENDS:=@TARGET_ps3||TARGET_ps3chk
   URL:=http://sourceforge.net/projects/libspe/
 endef
 
@@ -33,9 +32,9 @@ endef
 
 define Build/InstallDev
        echo "Build/InstallDev"
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP)   $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP)   $(PKG_INSTALL_DIR)/usr/lib/libspe2* $(1)/usr/lib/
 endef