FreeSWITCH:
[feed/telephony.git] / libs / libsrtp / Makefile
index 32884470095b767a99ab422f369b3c130d35b2c9..9118f4f3dae0c97cb757909736f0b5cb95ff6c4c 100644 (file)
@@ -23,18 +23,45 @@ include $(INCLUDE_DIR)/package.mk
 TARGET_CFLAGS += $(FPIC)
 CONFIGURE_ARGS += --disable-stdout --enable-syslog
 
-define Package/libsrtp
+define Package/libsrtp/Default
   SECTION:=libs
   CATEGORY:=Libraries
-  TITLE:=Secure Real-time Transport Protocol (SRTP) library
+  TITLE:=Secure Real-time Transport Protocol (SRTP)
   URL:=http://sourceforge.net/projects/srtp
   MAINTAINER:=Jiri Slachta <slachta@cesnet.cz>
 endef
 
+define Package/libsrtp/Default/description
+  Open-source implementation of the Secure Real-time Transport
+  Protocol (SRTP) originally authored by Cisco Systems, Inc.
+  It is available under a BSD-style license.
+endef
+
+define Package/libsrtp
+  $(call Package/libsrtp/Default)
+  TITLE+= library
+endef
+
 define Package/libsrtp/description
-Open-source implementation of the Secure Real-time Transport
-Protocol (SRTP) originally authored by Cisco Systems, Inc.
-It is available under a BSD-style license.
+  $(call Package/libsrtp/Default/description)
+
+  This package ONLY contains shared libraries. For development
+  libraries, please install libsrtp-dev package.
+
+endef
+
+define Package/libsrtp-dev
+  $(call Package/libsrtp/Default)
+  TITLE+= development library
+  DEPENDS:=+libsrtp
+endef
+
+define Package/libsrtp-dev/description
+  $(call Package/libsrtp/Default/description)
+
+  This package contains ONLY include files, static libraries, and
+  pkgconfig files.
+
 endef
 
 define Build/InstallDev
@@ -47,8 +74,15 @@ endef
 
 define Package/libsrtp/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsrtp.so.* \
-               $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsrtp.so* $(1)/usr/lib/
+endef
+
+
+define Package/libsrtp-dev/install
+       $(INSTALL_DIR) $(1)/usr/{include,lib}
+       $(CP) $(PKG_INSTALL_DIR)/usr/include $(1)/usr/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsrtp.a $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libsrtp))
+$(eval $(call BuildPackage,libsrtp-dev))