[package] update to transmission 1.71 (#5292)
[openwrt/svn-archive/archive.git] / libs / libtorrent / Makefile
index a3a87e8582fb0b1c2ed67f22efeed708a753e910..ce1b5948f3edaae77be0c0e1baae52bf7595cdbc 100644 (file)
@@ -4,15 +4,14 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libtorrent
 
-PKG_REV:=1087
+PKG_REV:=1093
 PKG_VERSION:=0.12.4_r$(PKG_REV)
-PKG_RELEASE:=3
+PKG_RELEASE:=6
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=svn://rakshasa.no/libtorrent/trunk/libtorrent
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
@@ -39,10 +38,11 @@ define Package/libtorrent/description
  the speed of the official client.
 endef
 
-TARGET_CFLAGS += $(FPIC)
+ifneq ($(CONFIG_GCC_VERSION_3_4)$(CONFIG_GCC_VERSION_4_1),)
+TARGET_CPPFLAGS += -fno-strict-aliasing
+endif
 
-TARGET_CPPFLAGS +=  \
-       -fno-strict-aliasing -fno-inline \
+TARGET_CPPFLAGS += -fno-inline
 
 # XXX: rtorrent needs encryption (--enable-openssl)
 CONFIGURE_ARGS+= \