[packages] libiconv-full: autoreconf is broken with this package, use patch-libtool...
[openwrt/svn-archive/archive.git] / libs / libvorbisidec / Makefile
index 5032e7dd6d0ba05c5555be3e27cd5f962bacfec1..a975bb766e6459d398abe0635c60d1d4354fdfca 100644 (file)
@@ -1,24 +1,22 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libvorbisidec
-PKG_VERSION:=1.2.0-dave
+PKG_VERSION:=1.0.2+svn14261
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://users.tpg.com.au/davico/openwrt/
-PKG_MD5SUM:=cb8e51aab92ef164f8e0e8853f7164fa
-PKG_CAT:=zcat
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
+PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/libv/libvorbisidec/
+PKG_MD5SUM:=bc617d4af1cd74b38d7c51451dd6eff0
 
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,72 +24,29 @@ define Package/libvorbisidec
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=A fixed-point Ogg/Vorbis decoder library
-  DESCRIPTION:=A fixed-point Ogg/Vorbis decoder library.\\\
-    libvorbisidec is "tremor", a fixed-point implementation of libvorbis.\\\
-    It also has libogg built-in. It is suitable as a replacement for \\\
-    libvorbis and libogg in tremor-aware applications.\\\
-    Tremor is a decoder only. 
-  URL:=http://http://wiki.xiph.org/index.php/Tremor
+  URL:=http://wiki.xiph.org/index.php/Tremor
 endef
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(strip $(TARGET_CFLAGS))" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --enable-shared \
-                       --enable-static \
-                       --disable-rpath \
-                       --with-gnu-ld \
-       );
+define Package/libvorbisidec/description
+       libvorbisidec is "tremor", a fixed-point implementation of libvorbis.
+       It also has libogg built-in. It is suitable as a replacement for 
+       libvorbis and libogg in tremor-aware applications.
+       Tremor is a decoder only.
 endef
 
-define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Package/libvorbisidec/install
-       install -m0755 -d $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libvorbisidec.so.* $(1)/usr/lib/
-endef
+TARGET_CFLAGS += $(FPIC)
+CONFIGURE_ARGS += --enable-shared --enable-static
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/tremor $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libvorbisidec.{a,so*} $(STAGING_DIR)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/tremor $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libvorbisidec.{a,so*} $(1)/usr/lib/
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/tremor \
-               $(STAGING_DIR)/usr/lib/libvorbisidec.{a,so*}
+define Package/libvorbisidec/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libvorbisidec.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libvorbisidec))