[package] update vpnc to 0.5.3 (#5648)
[openwrt/svn-archive/archive.git] / libs / opal / Makefile
index 312c46a29a20111438ab1280539245e74b81b035..e9df445f4fd0533aa6b5cedd63d81bf648a1fd1c 100644 (file)
@@ -4,24 +4,21 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 8274 2007-07-31 11:22:44Z nbd $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opal
-PKG_VERSION:=3.1.2
+PKG_VERSION:=3.2.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-src.tar.bz2
 PKG_SOURCE_URL:=@SF/opalvoip
-PKG_MD5SUM:=07fd0ed5ae95e1b88874e1fb9669e4f3
+PKG_MD5SUM:=405ba3b03ec706b6e6f873de340937e2
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)
 
 # Set location of ptlib (Which needs to have been built already)
-export PWLIBDIR=$(BUILD_DIR)/ptlib
 export PTLIBDIR=$(BUILD_DIR)/ptlib
-export PWLIBPLUGINDIR=$(BUILD_DIR)/ptlib/plugins/ptlib/
 export PTLIBPLUGINDIR=$(BUILD_DIR)/ptlib/plugins/ptlib/
 
 include $(INCLUDE_DIR)/package.mk
@@ -38,9 +35,10 @@ define Package/libopal/description
        Open Phone Abstraction Library, implementation of the ITU H.323
        teleconferencing protocol, and successor of the openh323 library. It
        supports not only the H.323 protocol but also SIP and IAX2.
-
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-audio \
        --disable-video \
@@ -67,8 +65,4 @@ define Build/InstallDev
        ln -sf $(PKG_NAME)_$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
 endef
 
-define Build/UninstallDev
-       rm -rf $(BUILD_DIR)/$(PKG_NAME)
-endef
-
 $(eval $(call BuildPackage,libopal))