[package] update vpnc to 0.5.3 (#5648)
[openwrt/svn-archive/archive.git] / libs / opal / Makefile
index 8d1c9aaffde2cbdb7d2407894e78f698cb89565a..e9df445f4fd0533aa6b5cedd63d81bf648a1fd1c 100644 (file)
@@ -4,41 +4,54 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 8274 2007-07-31 11:22:44Z nbd $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opal
-PKG_VERSION:=2.3.1
+PKG_VERSION:=3.2.1
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://peternixon.net/pub/voxgratia
-PKG_MD5SUM:=5a9d7f060527885bed3a26324de6dcfc
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-src.tar.bz2
+PKG_SOURCE_URL:=@SF/opalvoip
+PKG_MD5SUM:=405ba3b03ec706b6e6f873de340937e2
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)
 
-# Set location of pwlib (Which needs to have been built already)
-PWLIBDIR=$(BUILD_DIR)/pwlib-1.11.1
+# Set location of ptlib (Which needs to have been built already)
+export PTLIBDIR=$(BUILD_DIR)/ptlib
+export PTLIBPLUGINDIR=$(BUILD_DIR)/ptlib/plugins/ptlib/
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libopal
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+pwlib +uclibcxx
+  DEPENDS:=+ptlib +uclibcxx
   TITLE:=Open Phone Abstraction Library
-  DESCRIPTION:=\
-       Open Phone Abstraction Library, implementation of the ITU H.323\\\
-       teleconferencing protocol, and successor of the openh323 library. It\\\
-       supports not only the H.323 protocol but also SIP and IAX2.\\\
-  URL:=http://www.voxgratia.org/
+  URL:=http://www.opalvoip.org/
 endef
 
+define Package/libopal/description
+       Open Phone Abstraction Library, implementation of the ITU H.323
+       teleconferencing protocol, and successor of the openh323 library. It
+       supports not only the H.323 protocol but also SIP and IAX2.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
-       --enable-minsize \
        --enable-audio \
-       --disable-video
+       --disable-video \
+       --enable-sip \
+       --enable-h323 \
+       --disable-iax \
+       --disable-h224 \
+       --disable-h450 \
+       --disable-h460 \
+       --disable-ivr \
+       --disable-rfc4175 \
+       --disable-versioncheck \
+       --enable-localgsm
 
 CONFIGURE_VARS += \
        CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti" \
@@ -49,11 +62,7 @@ MAKE_FLAGS += \
        optnoshared
 
 define Build/InstallDev
-       ln -sf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
-endef
-
-define Build/UninstallDev
-       rm -rf $(BUILD_DIR)/$(PKG_NAME)
+       ln -sf $(PKG_NAME)_$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
 endef
 
 $(eval $(call BuildPackage,libopal))